Nano Stuck in Recovery Mode


I purchased an evaluation kit not long ago and immediately out of the box it wouldn’t boot (with a properly flashed card).

I purchased a second kit, created a new SD card, booted it and updated with the SDK manager. No problems with this kit.

I’ve taken the working SD card out of the second kit, placed in the first kit (non-functional) and it displays the same issues as it did originally. Nothing shows up on HDMI, screen doesn’t recognize any signal. When I hook up a console port (confirmed hooked up correctly on second kit) I see no output on the screen. When I plug in a USB cable to the micro-USB port (J28) and attach to my computer (powering from 5V 4A barrel connector), I see the following addition

xx@yy:~$ lsusb
Bus 003 Device 065: ID 0955:7f21 NVidia Corp. 

This appears to be the same result if I force the working kit into recovery mode. Anything I can do to get the first unit out of recovery mode?


If the unit can’t be taken out of recovery mode, then I’d say it is time to RMA.

Yep, that was my thought too. Customer support told me I needed to have a moderator ok an RMA before they could proceed, so here I am.


i was able to fix this issue by running it through micro usb cable, then properly shutting it down. after that i tried running it using DC and i got HDMI feedback, but kept getting stuck at nvidia logo. after that i tried booting with a fresh image and it worked.

i even flashed it through sdk manager and it worked.

acsmith, I would try ibondokji’s suggestions and re-flashing the device with SDK Manager or the L4T script. That will re-flash the device’s bootloader in case there is some issue there.

Baring that, if you still can’t get it out of recovery mode and booting, you have our approval for RMA. Sorry for the trouble!