Jetson Nano isn't showing HDMI output and not being detected by the PC

Hey Guys.
I spent countless hours trying to figure what’s wrong with my NVIDIA Jetson Nano.
I tried getting help from the community but seems like this is a new problem and does not have defined solution.

I purchased the Jetson nano few months ago, Installed the OS and followed all the required step, It worked fine for few days.
Few days later the Nano refused to boot up. I tried flashing (But the Nano isn’t being detected by the pc).
I have Ubuntu: 21.10 (I have an Idea that sdk manager does not work for Ubuntu 21.1, but primarily the target isn’t being detected by the pc )

I then tried lsdev and ifconfig and came to know that it isn’t being detected.

Any help would be appreciated.
Thank you.


This sounds not new issue at all… very common here.

Did you put your board into recovery mode before connecting to PC?

I just checked your activity, didn’t you ask same question last month?


Yeah, But the issue isn’t Resolved.
and I got busy with my exams, so didn’t got time to work with this.

please use the jumper on the Force recovery mode pin on your jetson… if you don’t put the board into recovery mode, then PC won’t be able to detect and flash it…

1 Like

That did work, Thanks Mate.
But, I’m Still not getting the HDMI output.
Not even the NVIDIA Logo pops up on the screen.

Are you still using ubuntu 21 doing the flash?

I wont be able to flash. because :

Then you can only move to ubuntu 18.04.

I don’t know if you understand what you are doing here.
If you put the board into recovery mode, the only difference is the board is able to be flashed by your host. Nothing else changed.
Recovery mode is just indicating “ok, the board is ready for host to flash”.
If you don’t flash the board, then it won’t have HDMI back to work. The status is same as previous one.

Thank you for simplifying.
I’ll try flashing and let you know how it goes.

I installed the sdk manager tried running with the instructions mentioned by linuxdev on previous post.
But it still doesn’t work, I’m getting an unusual error this time and even the board isn’t detected by the sdk manager.

PS: This time I’m trying to flash using Ubuntu 18.04.

Also, This is taking longer than expected, I already missed a deadline for my Major Project.
Is it possible for anyone to walk me through this possibly on zoom or google meet.

Thank you.

There is no such service here.

Also, I think you better sharing some info (e.g. log, screenshot, lsusb result) instead of only telling others “doesn’t work”.

Seriously, if you don’t want to waste your own time, share some useful info more than just “it doesn’t work”.

Take a silly example, if the board is not powered on, then of course it won’t be detected. I understand that you may not have such silly mistake, but the info you provided has nothing different from such case.

Firstly, After powering on the jetson nano via 5V-4A DC input, I used the dongle to connect with the Wi-Fi.

I tired ipconfig on windows CMD to detect the Jetson Nano. The Jetson nano didn.t show up.
I tried ifconfig on ubuntu still it was not being detected.

(Let me clarify : The Jetson Nano was connected to the Wi-Fi network initially when it was working fine.)

Moving on I connected the Nano to the laptop via USB and tried lsusb on ubuntu but still the Jetson nano was not getting detected.
I tried this on Ubuntu (Virtual Machine as well as dual boot) and also with the Windows.
In windows I checked it via device manager, I did saw APX but the drivers were missing. I tried Updating the drivers but it gave error dialogue box. Hence the drivers were not being updated.

I even tried connecting it via the recovery mode, still no success.

HDMI output is still an issue.
There are no videos on youtube and no articles on Internet mentioning the solution for this issue.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.


  1. Please just test with a non-VM ubuntu. Windows machine has no help here.

  2. Please just forget about ethernet or wifi. Focus on putting the board into recovery mode.

Also, just to make sure you didn’t put it wrong. You are connecting the micro usb port on the jetson but not other usb ports, right?