Can't boot my Jetson Nano 2GB - stuck on frozen NVIDIA logo

Hi, I’ve been trying to boot my Jetson Nano 2GB over and over again, but to no avail.

I’ve made sure that it’s being powered by a 5 V 3 A raspberry pi power source, and tried it with both of the following images:

I am using a 64 GB GoStar SD Card. I also tried with a different 64 GB GoStar SD Card, and with a 32 GB card (I don’t know the brand for this one).

When I try to boot, the HDMI output of the Jetson Nano looks like in the following post: Nvidia Splash Screen Frozen - #9 by mrmattrains

Please flash it with sdkmanager.

I did actually try with sdkmanager once, but I was unable to get it to detect my Jetson Nano. I’m not as familiar with sdkmanager though, so I could have set it up wrong potentially.

I had a USB cable from the computer with the sdkmanager connected to the MicroUSB port of the Jetson Nano (the one used for Device Mode). I was powering the Jetson Nano with a 5 V 3A adapter through the USB-C port. With this setup, I was unable to get the sdkmanager to detect my Jetson Nano, even after hitting refresh multiple times.

And even if it did, sdkmanager told me that there were no valid Ubuntu 20 images I could have flashed onto it for some reason.

The things you need to do is almost same as this post. Thus, you could refer to this first.

Alright, I followed the instructions in that post to put my Jetson Nano 2G into Recovery Mode.

Here is how I put in the pins:

This is how I powered it and connected it to my Linux Machine:

However, even after waiting minutes and hitting refresh, it still doesn’t appear. I added the pins before powering the board.

@WayneWWW

Is your host machine a VM?

Does your micro usb cable have data line but not just power line?