Jetson Nano Developer Kit restoring raw image

Hi all.

After two days messing with this thing, Ive decided to ask for help.
Namely, I have managed to create raw backup of my Jetson nano module (no-SD card version, eMMC only).
I’m having difficulties restoring that same image to that device (for testing purposes).

Command that made the image is: sudo ./ -r -k APP -G /media/user/Data/nano/backup.img jetson-nano-emmc mmcblk0p1

that worked. Now please, how to restore this same image to that same board.

Jetson is in recovery mode as I can see it with lsusb and it shows up as: ID 0955:7f21 NVidia Corp.
Ive tried: sudo ./ -r jetson-nano-emmc mmcblk0p1 /media/user/Data/nano/backup.img
and it is a no-go (also goes for many different string but Im to embarrassed to type that sh!t here:) .

Anyway, running this command casts an “Error: Invalid target board - mmcblk0p1”

So basically, I’m having issue restoring my backup to that same device device.
I’m not an developer, so my understanding of certain approaches to this issue is questionable.

Thank you for any pointers and your time.


moving this to Nano

hello neurosis,

please refer to Flash Script Usage, you’ll need to enable -G options to reads the boot partition and saves the image to the specified file.
thereafter, you may read and back-up the image, you should replace the original system.img with the one of yours.

please perform whole flash commands with -r options specified. it’ll skips building system.img; reuse the existing one.
you may execute the commands to restore it. for example, $ sudo ./ -r jetson-nano-emmc mmcblk0p1

Added detail: The file “Linux_for_Tegra/bootloader/system.img” is what gets flashed (at least for the root filesystem, but there are other boot-related partitions). If you use “-r” option to an otherwise basic flash command, then that file is not regenerated prior to flash. Whatever file is there gets used in the case of “-r”. If your backup image is copied to the file name “Linux_for_Tegra/bootloader/system.img”, then it is flashed. The “normal” system.img is created from the sample rootfs in the “Linux_for_Tegra/rootfs/” directory, and you need to skip that step.

Do know that there is a dependency between the rootfs content and the non-rootfs partitions. If the L4T or JetPack/SDKM version used to restore is different than the release version which created the original backup image is mismatched, then chances are boot will fail.

1 Like