Reseting Jetsons nano rom

i accidentally flashed the 2g version of the system on my jetson.
I tried to flash the correct version, but it seems that somehow the board saved some configuration in internal storage. So when i put new SD in, nothing changes, it boots but all files and everything is the same.

How do i reset the internal memory?
Any help would be appreciated;)


Welcome to the NVIDIA Developer forums! This topic belongs in the Jetson Category.

I will move it over for you.


You can try with the SDK manager to flash your devcie via the JetPack.
You need to have a host PC with Ubuntu 18.04.

I tried it, but how can I connect to it while the system isnt working. Like it wants ip adress and ssh. But the jetson is showing only INVIDIA logo and not doing anything. Is there a way to flash it using only USB?

Hi hajnyondra,

Please follow below steps to flash by manually:

  1. Put jumper on J40 pins 3 and 4. Reference detail from Jetson Nano Developer Kit.
  2. Download L4T Driver Package and Sample Root Filesystem from: Jetson Linux R32.7.2 Release Page | NVIDIA Developer
  3. Follow Quick Start steps to flash image.

Sorry, but the link is the first step is not working (
What should I do?

Hi hajnyondra,

What’s mean not working?
Your host PC can’t see the device into recovery mode?

Well it can see it, it shows up as an nvidia devicem But the jetson isnt connected to the internet, and it wants to connect over ssh. That ist going to work…

Hi hajnyondra,

Flash by manually doesn’t need internet.
After put device into recovery mode, then follow steps 2-3 to prepare the BSP package on your host PC.

Well I also have a problem with the webpage of the quick start. The link seems to be broken…

Could you provide another one please?

Hi hajnyondra,

Please check from: Jetson Linux Developer Guide (online version)
Quick Start → Preparing a Jetson Developer Kit for Use → To flash Jetson Developer Kit operating software

$ cd Linux_for_Tegra/rootfs/
$ sudo tar xpf ../../${SAMPLE_FS_PACKAGE}
$ cd ..
$ sudo ./

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.