Unable to reflash the yahboom jetson nano using sdk manager but formatting of nano is completed

I have followed these steps which formatted the yahboom jetson nano:

Then I followed these steps:

Now jetson nano is unable to reflash using nvidia sdk manager which is as follows:


If you already got the Ubuntu system working on your device, and just wanted to install JetPack SDK,
then SDK Manager is not required here. Run these commands on your device:

sudo apt update
sudo apt install nvidia-jetpack

Also, please use screen capture instead of taking pictures of the screen itself…
Don’t you think the moiré pattern make the picture hard to read?

Hi DaveYYY,
Thanks for your reply. Finally, the yahboom jetson nano is formatted as per the first link. Now I want to reflash the yahboom jetson nano with internal emmc chip as I had already done changes to dtb and bootloader dtb files as per the second link given above.
Could you please help me how to reflash the nano board?
Imran patan.


你說要改device tree的話就要自己用script燒,SDK Manager只能用預設的BSP
而且你貼的那張圖是已經燒完L4T的Ubuntu系統之後,要燒JetPack SDK才要做的,請問你到底是停在哪一步?

還有你貼的那兩條連結都是用指令flash,為什麼又突然跳出SDK Manager?

Hi Daveyyy,
Sorry for the inconvenience. Please translate the text in the browser and I don’t know chinese as Iam an Indian. I tried to reflash the nano using nvidia sdk manager as the only method known by my knowledge as a beginner on this nano module. I am stuck at the point shown in the picture. But if there is any alternate method to reflash the nano for jetson OS please help me out.
I got the above links through yahboom website and trying different methods as per the search in the google. Actually,I don’t know how to reflash the nano so please help me out.
Imran patan.

Oh well, then let me explain again.
I thought you know Chinese as you are referring to CSDN…

I actually have no idea what you are trying to do.

You said you made some modification to the device tree, then you cannot use SDK Manager to flash your device. They are meant to be used with only the default BSP provided by NVIDIA, and also DevKits.
Also, the image you posted is about installing JetPack SDK, which should be done after the L4T Ubuntu system is flashed into the device, and after the device boots into the system. So in what exact steps are you getting stuck?

Lastly, both links you posted are about flashing using scripts, then why SDK Manager popped up here?

Like, can you please make a summary of what you are trying to do and what you have done trying?
Is your changes to dtb made by yourself, or by the Yahboom vendor?

Hi Daveyyy,
The picture I posted isn’t about installing jetpack SDK,but is about flashing through nvidia Jetpack Sdk manager. I was trying to reflash the nano through jetpack sdk as far as I know. Now the changes to dtb are done by me through the reference link given above. So the method which I tried through sdk is failed and hence help me out with another successful method or steps to flash the jetson os in the nano board.
Imran patan.

You must have done something wrong before, but I cannot make sure from this single picture.
If you don’t know what I’m talking about, then whatever…

Anyway, this it the document you should be referring to:

sudo ./flash.sh jetson-nano-devkit-emmc mmcblk0p1

Hi Daveyyy,
I had tried the above method:

at the end but the nano is not able to show the flashed OS and booting,login screen on the monitor. Something would have gone wrong. So please help me to sort out the problem.


Attach the log or we cannot help you.
We need both flashing log and serial console log:

Hi Daveyyy,
Here is the serial console output while flashing through sdk manager.

Note:flashing process is being done in another laptop but iam replying you in other laptop so i took a photo and uploaded it. sorry for the inconvenience.


You are using SDK Manger while I told you to use flashing script as specified in the document.
Is it really that hard to understand?

Actually I tried both methods (scripting and sdk manager)to flash the nano but nothing worked out.

Then please dump everything you got by flashing with flash.sh.
Also the serial console log, by connecting the TTL-USB cable, during flashing.

How can I help you if there is only something like nothing worked out, but not any useful information/log?

I don’t believe you need DeepStream here.
Please just un-check everything except the L4T OS itself.

when i tried using script method by connecting jumper across force recovery mode and ground then it was successfully flashed but didn’t display anything on the monitor through hdmi cable. It was asked to restart the board ,then restarted, but nothing got displayed either taking off or connecting the jumper across the force recovery and ground pins.
Sorry for the inconvenience, i hadn’t exported the log files.

Then there is nothing we can do if you don’t have any log.
Maybe it’s caused by some buggy code in your customized dtb, so you’d better first flash with the default BSP and make sure at least it’s working this way.

Hi Daveyyy,
This method of disabling the deepstream has worked for me and the jetson os is successfully installed.

Thanks and regards,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.