Jetson Nano does not boot up

Hey,

Before a couple of days, I wrote by mistake to the wrong I2C port and since then I can’t use my Jetson Nano.

I tried to flash a new SD card without any success.

I tried to use SDK manager also without any success. The SDK manager identifies the Jetson Nano when I get him to force recovery mode but it failed in the installation.

I downloaded the logs from the SDK manager:
SDKM_logs_JetPack_4.6_(rev.1)Linux_for_Jetson_Nano[developer_kit_version]_2021-08-30_17-16-52.zip|attachment (90.0 KB)

I tried also to flash using the command:
./flash.sh jetson-nano-qspi-sd mmcblk0p1 - But when I try to find mmcblk0p1 in /dev I can’t find it.

The last thing that I tried is to do the headless installation but I couldn’t find /dev/ttyACM*.

Thank you,

Parsing baseboard EEPROM:
--- Parsing board ID (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
--- Parsing board version (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
--- Parsing board SKU (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
--- Parsing board REV (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
Parsing module EEPROM:
--- Parsing board ID (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
--- Parsing board version (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
--- Parsing board SKU (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
--- Parsing board REV (ERROR: calculated CRC8 0xd0 != stored CRC8 0x21) succeeded.
Error: Target board not found.

hello ophirg123,

according to those failures. had you overwritten eeprom by accident?
here’s developer guide, Jetson Module EEPROM Layout for your reference.

so,
it’s SDKManger to assign default board spec into flash command-line; you’re able to execute flash.sh and assign the info manually to re-flash the target.
for example, it’s BOARDID=3448;FAB=200; for the Jetson-Nano-DevKits. (FAB value will depends-on your board sku)
you can execute flash.sh to input the board info manually to re-flash the target.
i.e. $ sudo BOARDID=<> FAB=<> ./flash.sh jetson-nano mmcblk0p1

Thank you for the fast answer! This is exactly the wrong I2C port and address (“I2C bus 2, address 0x50”) that I wrote by mistake.

I tried to run the command: sudo BOARDID=3448 FAB=100 ./flash.sh jetson-nano-devkit mmcblk0p1
and it failed. logs.txt (9.4 KB)

I was not sure if I choose the right FAB and jetson-nano (devkit or qspi).

Then I tried to flash again from the SDK manager and now it seems that the errors are different:
SDKM_logs_JetPack_4.6_(rev.1)Linux_for_Jetson_Nano[developer_kit_version]_2021-08-31_14-00-17.zip|attachment (174.3 KB)

hello ophirg123,

you should try flash the board manually instead of using SDKManager.

did you remember what’s the values you wrote into this eeprom?
please refer to EEPROM layout and assign the values to the flash.sh.

Hey, sorry for the late answer, we are on holiday.

Unfortunately, I don’t remember which value I wrote.

Can you please guide whether I can download the current EEPROM values, or if there are default values to recover to?

hello ophirg123,

you can dump the eeprom by $ sudo i2cdump -f -y 2 0x50. if this board is bootable,
otherwise, you’ll need to program the same values to pass the flash process.

The board is not bootable.

Which values do I need to program and how?
You have maybe an example?

I got the logs from the flash process that I tried to do:
logs.txt (9.3 KB)

By the way now when I try to reflash, I get the message:
ophir@ophir-VirtualBox:~/nvidia/nvidia_sdk/JetPack_4.6_Linux_JETSON_NANO_TARGETS/Linux_for_Tegra$ sudo BOARDID=3448 FAB=0000 ./flash.sh jetson-nano-devkit mmcblk0p1
###############################################################################

L4T BSP Information:

R32 , REVISION: 6.1

###############################################################################

Target Board Information:

Name: jetson-nano-devkit, Board Family: t210ref, SoC: Unknown,

OpMode: production, Boot Authentication: ,

Disk encryption: disabled ,

###############################################################################
Error: The Actual SoC ID(0x42) mismatches intended jetson-nano-devkit SoC ID(0x21).

hello ophirg123,

it’s my assumption you’ve program the chip-id as 0x42, which should be 0x21.
please assign the tegraid with -x options, i.e. $ sudo BOARDID=3448 FAB=0000 ./flash.sh -x 0x42 jetson-nano-devkit mmcblk0p1
you should also modify the flash.sh to make it recognize this board.
for example,

        case ${hwchipid} in
        0x21) socname="Tegra 210"; mach_dir="t210ref"; ;;
+        0x42) socname="Tegra 210"; mach_dir="t210ref"; ;;
        0x18) socname="Tegra 186"; mach_dir="t186ref"; ;;
        0x19) socname="Tegra 194"; mach_dir="t186ref"; ;;

please have a try, thanks!

Hey Jerry,

I think we are making a little progress every time.

This is the error right now:
logs (1).txt (4.9 KB)

please refer to this post. The xml file is also needed for providing the board info.

Your parameters maybe different from this case because they are emmc module but yours is sdcard module.

I followed the link you attached and it seemed to start flashing the board, but it got stuck:

[ 168.0447 ] Writing partition APP with system.img
[ 7007.5419 ] … ] 017%
Error: Return value 3
Command tegradevflash --pt flash.xml.bin --storageinfo storage_info.bin --create
Failed flashing t210ref.

The logs:
2021_20_09_logs.txt (13.1 KB)

  1. Can you provide what you’ve added to the config file? Did you ever change the content inside xml file?

  2. Is your host a Virtual box?

Hey,

I modified the next files as they said on the other topic:
p3448-0000.conf.common -
+BCFFILE=“bootloader/${target_board}/cfg/board_config_p3448.xml”
image

p3449-0000+p3448-0000-qspi-sd.conf -
+BOARDID=“3448”;
+FAB=“000”
image

About your other question, YES I am using Virtualbox because I don’t have a pure Linux PC.

I read now that it is probably because of the VM.

They said that I need to set the USB to ECHI.

I will try that now.

Edit:
Now it got stuck at the line -
[ 0.3184 ] tegrarcm --chip 0x21 0 --rcm rcm_list_signed.xml --skipuid

I will try to do the whole setup at Linux PC. If you have other idea why it got stuck at that line, I will try it.