Jetson Nano hangs while running yolov5 using Deepstream

So I followed all steps on this repo, to run my custom trained yolov5 model on jetson nano using my csi camera and jetson nano (4gb).
However, after running this command, the terminal gets stuck after reading the weights and the model, and then the whole system hangs and I am forced to reboot.
As suggested on this nvidia-forum-topic I changed the source definition to accommodate my csi camera.
Can someone please help me understand why this is happening? And how can I fix this to get the predictions using the CSI camera?

Jetpack - 4.6
DeepSTream - 6.0
Its really urgent for me to solve this, please help me out!

As an alternative, is there is way we can use this code to run the yolov5 model using csi-camera on the jetson nano?

These are the files I primarily used and made a changes:
config_infer_primary_yoloV5.txt (656 Bytes)
deepstream_app_config.txt (813 Bytes)

which command? can you share the logs? you might redirect the log to a file, can you monitor the system CPU, memory usage?

it is custom code, we did not test it, you can use deepstream sample deepstream-app, here is the sample configuration csi camera, you might use the default mode to test first.

Hello, thank you for helping.

deepstream-app -c deepstream_app_config.txt

This is the command I ran after following all the steps in this repo

I dont know how to check the logs or the CPU and memory usage, and unfortunately I am unable to attach a screenshot for the same since after running the code my jetson nano just hangs and automatically reboots.

Can you please help me figure this out?

Update: I ran these two lines of code:

$ sudo nvpmodel -m 0
$ sudo jetson_clocks

And after this I ran the code again, it did work for initial 30-50 seconds, after which it hanged again and forced a reboot into my jetson nano.

Please help me understand how to avoid it from hanging.

Here are a few images I captured when it ran:

@fanzh Can you please look into my updated issue?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

to narrow down this issue, please check the following:

  1. can the simplest sample deestream-test1 run?
  2. if using yolov5, please run jtop to check if the CPU/memory are exhausted.
  3. if using yolov5, can you try local file as source?
  4. after rebooting, can you provide system log by “sudo /usr/bin/ -o system.log”? and a file in /sys/fs/pstore/ which is system log too.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.