Jetson Nano inputs stucks

,

Hi, I have a Jetson Nano input connected from an optocoupler, and it frequently stucks, with some voltage, when there is no external signal.

I have made the next video:

Any help would be appreciated, thanks for reading.

Hello,

Which pin is in use here?

Hello, I´m using pin 31 and pin 35 in that video (both with the same issue).

Any other question please let me know.

Thank you.

Hi, please refer to the 40-pin header docs first. There are some requests to the usage of these pins.

https://developer.nvidia.com/jetson-nano-developer-kit-40-pin-expansion-header-gpio-usage-considerations-applications-note

Hi, thank you for the link.

I have read it carefully but I´m afraid I’m missing something. I understand that maybe I need a pull-up or pull-down resistor but I don´t know if I’m properly connecting the optocoupler to the Jetson Nano pin, or if it is not possible. Just to clarify:

My circuit:

  • Jetson Nano:
    • VCC (5v) on PINs 2, 4
    • GND on PIN 6
  • Optocoupler with 24v inputs to 3.3v outputs
    • VCC (3.3v) from Jetson Nano PIN 1
    • GND from Jetson Nano PIN 9
    • its ouptuts (O1, O2) connected as inputs to Jetson Nano PINs 31 and 35

I have also tried with a pull-down resistor (2K), but issue stills the same.

Should I connect all GND PINs (6, 9, 14, 20, 25, 30, 34 and 39) to ground like the example in documentation?
Should I connect PINs 1 and 17 to 3.3v like the example in documentation?
Is it possible in any way a working circuit with Jetson Nano and that optocupler?

Thanks and kind regards.

No experience on this kind of 3rd-party device connection. You can check with vendor for how to connect it to other device.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.