Jetson Nano is not opening(booting) when nano is connected to m2key converter with a PCI video capture card

Hello,

Jetson Nano is stuct at Nvidia icon then I lost the display at all when nano is connected to m2key converter(it is plugged to the m2key port) with a PCI video capture card. I use same setup on Jetson TX2 and it works fine. M2 key part is working because I tried it with a wifi module.

By the way Nvidia icon appears with low resolution. I used both power options power jack and micro USB with MaxN power mode. It does not work.

Thanks for your helps.

Are you able to dump the boot log from UART? What m.2 device are you using?

Thanks for your answer Wayne. I am able to take boot log from UART. Still the same result with PCI there is no boot log. I guess, my UART connection deos not take power from the board pins when PCI is plugged. Without PCI, I can take the boot log from UART.

Here is my m.2 device;

https://www.delock.de/produkte/G_62848/merkmale.html?setLanguage=en

Crocus,

Are you sure the UART log does not show anything if you connect the device in the beginning? Even the log in bootloader?

Yes I am sure. As I said only NVIDIA logo screen comes with low resolution view then before boot I lost the whole display.

I couldn’t find the solution. Are there anyone who has same issue?

Can you please remove M.2 connector altogether and get the logs? with M.2 converter, you should be able to get the logs, otherwise, I would say there is something wrong with the setup in terms of UART. Once you get to the point where you could get logs from the system without M.2 connector, collect logs after connecting M.2 connector.

Thanks for your answer. I did what you say and collected the logs. It is hard to see the difference between m.2 key converter and without it, where do I need to look? With the PCI video capture card again Nano is not even boot only Nvidia logo shows up.

Crocus,

Please help check if my summary is correct or not

  1. M.2 converter connected but no device
    -> UART log works fine and boot into system.

  2. no devices, neither the M.2 converter.
    -> UART log works fine and boot into system.

  3. M.2 converter + PCI video capture card
    -> UART log is dead and only boot logo is there.

Do you have other pcie card that can test?

Wayne,

All of them true. In third one, after few seconds logo is also gone.

I don’t have an another pcie card.

Crocus,

Could you share what video capture card you are using?
I think you better finding another pcie device to test if it always breaks down the UART.

It is not common that something causing UART log to disappear.

Hi Wayne,

Here is the capture card DVP-7041E.

https://www.advantech.com/products/video_capture_board/dvp-7041e/mod_9e245aa8-df73-49e1-a295-609fee702260

Hi Crocus,

We think your card is pulling I2C lanes low because of which it is not going ahead and hence not even prints are seen. This case happens to some NIC too.

There seems no other way to proceed unless there is a change in the way I2C lanes are routed. I mean the hardware change.

Thanks for your answer Wayne,

Do you have any suggestion for a video capture PCI ?