Jetson Nano PiOLED, fan, KB mouse failure

Had the Jetbot working the night before. When I woke up, the fan and PiOLED were not working. I tried rebooting, with no luck, so I tried a new (different) SD card, with no luck. The unit EVENTUALLY gets to a desktop, but the KB and mouse don’t respond at all and the fan and PiOLED won’t run

I unplugged everything that was unpluggable, IE system board, jumpers, fan, WiFi card, anything plugged into UISB, and blew it off, thinking that something might have fall into it to short something, but, I’m still getting no response from it

It shouldn’t have had a power issue, because it was plugged into an APC UPS, and the APC is reporting no issues

I’m kind of at a loss as to what I can do to recover the unit

Is there a (preferably simple) known fix for this kind of issue ?

hello spyder19,

so, the Nano platform still works but it’s failures with peripheral?
could you please share kernel logs for reference,

Is there any way I can get those logs from the SD card if I mount it on my PC, or maybe another linux box ? I can’t get into the thing at all. It’s just a brick with a desktop

Well, skip the PC . The PC doesn’t seem to like the Jetson SD card

Ok, it opened on a Raspberry Pi. Exactly where should I find what you’re looking for ?

hello spyder19,

please refer to Jetson Nano - UART - JetsonHacks to gather logs via UART console.

I don’t have a TTL cable, so I had to order one. It should be here in a couple of days. I’ll post when I have your data

It refuses to answer me.

I’ve got the HDMI plugged in, so I can see that there’s a desktop there, and the TTL cable is telling me that it’s on COM11, but, it simply doesn’t answer me when I try to TTL-SSH into it

Lights on-nobody home

Unless you can tell me where to find those logs in an offline scenario, I can’t give you the log

What’s next ?

hello spyder19,

how about ssh to the target since you’re able to boot into ubuntun desktop, using $ dmesg > klog.txt to gather kernel messages.

Yea. I thought I made that clear. I’m trying to ssh into the thing from my windows box via a TTL-USB cable on pins 6, 8 and 10 on the J41 header (using the instructions described in the jetsonhacks webpage you sent in a previous post)

I’m only using the HDMI connected to the monitor so that I know when it’s up.

It’s not answering on SSH via the TTL-USB cable, or thru the KB/Mouse, and the network monitor in my router says that it doesn’t exist on my network, so SSH thru IP is also out of the question

hello spyder19,

you cannot use ssh. TTL-USB it’s serial UART protocol.
please have a try with Serial Port Utility since you’re working with WindowsOS.

besides, please wire your ethernet port with RJ45 cable, it should register eth0 automatically.
you may execute the commands, ifconfig -a to check the IP address of the target, then you’ll able to access it via ssh.
for example, ssh nvidia@11.22.333.456

The JetsonHacks link you posted for me to follow described using a program called “putty” in serial mode as a “Serial Port Utility” (note timestamp 2:59 in video) which is what I did. I simply referred to it as “ssh” because that’s what I typically use putty for. Perhaps I should have been more precise in the use of my language and said that I attempted to “serial” into the Jetson Nano as opposed to saying that I attempted to “ssh” into the Jetson

The TTL cable that I bought showed up on COM11, which is what I set the putty program for, and the suggested speed of 115200 as per the video is what I set the serial port utility for.

The Jetson is not answering me in any way, shape, or form, when I attempt to use the serial port utility VIA TTL-USB cable to access it

hello spyder19,

please refer to this topic for the port connections, Serial port 1 data loss occasionally - #5 by yzh03

you’re using Windows Operation System, right?
in my experience, Serial Port Utility just works with Windows7 and Windows10.

please also have a try by stopping and disabling the nvgetty service.
execute below commands on Nano to starts a console on ttyTHS1.
$ systemctl stop nvgetty
$ systemctl disable nvgetty

I have windows 7. The putty serial port utility works just fine… when the machine I’m trying to log into is functioning

This one… ISN’T

I do not have occasional serial port data loss, it’s permanent because the Jetson isn’t functioning properly

I can’t give ANY systemctl commands because the Jetson isn’t functioning properly

I think it’s time to either escalate this, or issue me an RMA

why RMA? don’t you see the system boot-up successfully?
please review your pin connections, please share a snapshot also.
BTW, don’t you have USB ports on Nano DevKit to setup I/O devices.

No. I can’t connect to the thing at all. I have no idea why the HDMI lights up, but it does nothing, and I can’t connect to it via serial port

It’s acting like it’s locked up. Nothing seems to be functioning

Yes, as you well know, the thing comes with USB ports, but those don’t connect either.

I’ve tried every method of connecting that I can think of. It’s acting like it’s just locked up

please contact the NVIDIA Customer Care team for RMA process if you believe that your Jetson product is defective.