Jetson Nano 4GB is not booting after I ran a python program and it crashed

I was recently working with my Jetson Nano 4GB developer kit with the latest jetpack installed in it and I was using it to make an object detection bot. On 1st May 2021, I was trying to run my semi-finalized code and tested it running on my bot. It was working when I ran the code for the first time with TightVNC. I tried to run it again and the code started for few seconds and I lost connection to TightVNC. I thought there was some disconnectivity issue but I found that TightVNC was not getting connected. I tried to connect jetson to the Monitor screen and I was getting long bootup messages instead of the Nvidia logo and normal ubuntu GUI. I tried to use a different SD card with a new jetpack but when I did that I was only able to see the first page of the license agreement because the mouse and keyboard plugged in were not working (my mouse and keyboard works well with my laptop). I also tried to use a serial cable to run it with PuTTY but it is not working as well.

Joy Pillai

I also tried to use a serial cable to run it with PuTTY but it is not working as well.

What is your setup for putty? What command are you using here? What error did you see?

I used usb cable to connect jetson nano via PuTTY. Serial line: COM3 (I checked it in device manager) Baud rate:115200
After I click OK on PuTTY I see this error
But after 5 attempts I was able to see the terminal. I tried to login and found that it was very slow. After every 10-15 seconds I was able to see what I was typing. I somehow managed to check my files and I found that it was safe and nothing was corrupted.

Do you connect the usb cable to micro usb port on nano or on the UART pin?

micro USB

If you can still connect it, please dump the dmesg and attach it here.

If it is not stable to dump, use below method to access the serial console.

Also, what kind of python script is that? What is it doing?

The python script I wrote was to control motor so I used pin 11 and 12 as direction pin, pin 33 and 32 as pwm pin. I had also connected arduino with USB and I was receiving data from arduino. I used 5-6 threads to run my code parallelly.

Still need your log to see what is going on.

This is the copied dmesg log from the PuTTY terminal
I am not sure if this is useful. Could you suggest me a way to do it, if I am using a USB cable
dmesg.txt (111.8 KB)

I see the cpu is crashing and also the wifi firmware has error too. Your log starts after timestamp 1607. Do you have a log that contains boot process?

Actually, I would suggest you can use some empty sdcard and try sdkmanager. If the board is not getting back to normal after re-flash, then you may need to RMA this board.

I have tried to use a different SD card with new jetpack in it. But it doesn’t work.

Also my mouse and keyboard are not working with jetson board when I try using new SD card.

Again, use the UART to dump the log. I guess the micro usb port no longer works.

You just show me a picture and told the disk space is not enough. No sufficient info to check.

Hello Wayne

I don’t have USB to UART cable right now. I will send dmesg log as soon as I buy it.
One more thing,
I was trying to extract initial time stamp log from the old SD. It took me several hours to connect nano to PuTTY…
dmesg_new.txt (6.9 KB)

Why you only dump 100 line here? Is there any difficulty to just dump the full log?

Also, do you use sdkmanager or sdcard image for your so-called jetpack here?

Hello Wayne
Thanks for the quick response
When I try to dump the full log, the upper part gets cleared in the terminal automatically. I have tried it once again
dmesg_newlog.txt (107.7 KB)

I am sorry Wayne, actually Linux and Jetson are new for me. I have downloaded SD card image in the new SD card from: JetPack SDK | NVIDIA Developer

Please try to find a x64 ubuntu host and try sdkmanager.

If even sdkmanager cannot bring your board back, then you can file a RMA request.

Just want to confirm, do you still have those tools running? Or device is in idle state but still has problem?

Hello Wayne

I am sorry I don’t get it which tools are you talking about? If you are talking about external hardware then NO. I have only connected Jetson Nano to 5V DC barrel jack adaptor and a USB cable and nothing else.
I will try SDK Manager and let you know.

Once again thankyou Wayne

Yes, I am talking about the external hardware. Waiting for your result from sdkm.

Hello Wayne

I had to change my Ubuntu 20.04 to Ubuntu 18.04 to make sdkmanager run, so it took me some time. I tried sdkmanager and downloaded/installed all the dependencies and I was following all the procedure (connecting the recovery pin and then powering ON) but unfortunately I was not able to connect the board via SSH.

Should I start with RMA procedures?