Jetson Nano setup Docker download failed

After running the following

echo "sudo docker run --runtime nvidia -it --rm --network host \
    --volume ~/nvdli-data:/nvdli-nano/data \
    --device /dev/video0 \" >
chmod +x

It ask for my password and then begins downloading, but it runs into the error on the image below and wont finish the download so i can access jupyter.
Any suggestions?


Moving to Jetson Nano forum for resolution.


It seems that the issue photo is not shown correctly.
Could you update it again?


I lost the picture I took in snip it. I tried to download the docker when doing so it failed to download and gave me the error message. which I cannot seem to replicate. Now when I run the docker script ( ```
echo “sudo docker run --runtime nvidia -it --rm --network host
–volume ~/nvdli-data:/nvdli-nano/data
–device /dev/video0” >
chmod +x

I get the below message. I went ahead and ran ls so you could see the directory.


Sometime the downloading may fail with some network issue.
Could you run the docker successfully now?


Hi @matthewT95, I was able to edit your posts so we could see the error messages, and they seem unrelated to downloading the container (rather, running it). Here are some suggestions:

  1. First error you can get when your L4T version doesn’t match the container version. Run cat /etc/nv_tegra_release and make sure the L4T version that is reported matches the version in the container tag. For example, if you are running L4T R32.5.0 (JetPack 4.5), then use the container instead

  2. Second error you can get when you don’t have a camera attached, but you are still trying to mount /dev/video0. So remove the --device /dev/video0 line from your docker run command until you attach a camera. If you do in fact have a camera attached, check ls /dev/video* to see if it showed up under a different /dev/video device.

1 Like

if i have JetPack 4.5.1 i can still use

Hi @rajkumarsaswamy, yes JetPack 4.5.1 (r32.5.1) does not require a new Docker base - you can use the JetPack 4.5 (r32.5.0 containers with it.