Jetson nano unable to find image

So I was following the videos for the headless device mode setup and everything was fine until I got to the part where it says to run the docker container when I try it it says enter password then I enter it then I just says unable to find image. Did I download something wrong?

Can you paste the full log here?

And what video are you referring to? What did you download?

But when I try to run it it just shows this:

these are the codes I am trying to run

Am I doing something wrong?

I downloaded the docker image but I don’t know if it worked

Hi @groot80123, are you able to do:

sudo docker pull

If so, try re-running the sudo docker run ... command you used above and see if it starts this time.

Also, can you check which version of JetPack-L4T you are running with cat /etc/nv_tegra_release? If it is L4T R32.5.0, use the container instead.

This is what it says

@groot80123, I can’t see the whole error message from screenshot, but it appears to be some connection issue. If you reboot and try again does it work now?

This is what it shows I have rebooted it and it shows the same thing

What am I doing wrong

Are you able to ping from your Nano in your SSH session there?

If not, the internet connection sharing through your PC may not be working, and I recommend connecting your Nano to your network router via ethernet or wifi to pull the container.

Hi! I am facing the same issue. I get the error of " Unable to find … image". I have tried every solution I have seen on the internet but its not working. I even flashed a new sd card and it still wasnt working. I changed the version to fit mine (4.4, 5.0, 5.1), tried every thing on this site as well (Docker_dli_run error - #2 by rajkumarsaswamy) , tried the “ping” and it could run showing that it was connected to the internet (mine was via ethernet). I have basically tried everything I can, but I still get the same error. Please I will greatly appreciate your help. I have already spent an entire week on this trying to figure it out

Hi. I was able to get it working. I had to change my time setting in Putty (since I am using a windows computer). I used this ( Linux: set date through command line - Unix & Linux Stack Exchange) for the time/ date setting. I added sudo to it (i.e $ sudo date -s…). I then tried with image 5.1, it didnt work, tried 4.4 it downloaded but gave an error and then I tried 5.0 which finally worked. Hope this helps.

Hi, which time did you change? Jetson or the computer? does it mean you had a time difference issue between the two?

I have the same handshake timeout problem. Both my Laptop and Jetson have the same time/date.

My issue was simply the slow connection I had on the Jetson. Once I changed it to a faster network (same as the one running on the Laptop), I was able to pull everything.