Troubleshooting with Jupyter Docker

I am trying to use the NVIDIA provided terminal code on MAC to create a docker on my jetson nano that will run Jupyter for image classification. I am receiving a “permission denied” error. An image is shown below. Any help would be appreciated!

Hi @jpurpura37, can you run chmod +x That should give your script executable priveleges.

Also as an aside, you may want to check that your L4T version matches the container tag - you can check your JetPack-L4T version with cat /etc/nv_tegra_release. For example, if you are running L4T R32.5.0, you would use instead. The exception is that L4T R32.5.1 also uses the r32.5.0 container.


I tried it with all the tags and none of them worked. I now have permission to enter my password but now I am receiving an error that it cannot find my device?

Can you run sudo docker pull

If not, is your Jetson connected to the internet?

The internet connection could be the issue here. Does the Jetson not automatically connect via my computer when connected through micro usb?

Are you able to ping If not, the Internet Connection Sharing (ICS) with your PC isn’t working. It may be easiest just to connect your Nano to your router or wifi if you can.

What would be a good resource for connecting it to wifi through my terminal?

I am now connected to the internet but I am still receiving the error that it cannot find the image locally

Can you now sudo docker pull

I tried that but i am getting the error that my request gets canceled while waiting for connection. My Jetson is connected via ethernet however so I am not sure what is going on. This has been the error I get after trying it several ways

Are you able to ping Is your Ethernet cable plugged into your router?

I got everything to work now, I had to reflash my SD card because nothing was working right. I did notice however that in the image classification tutorial here the link to open JupyterLab does not work, it says the site cannot be reached. Do you know if there is an updated/different link?

Do you mean there is a page on the DLI website isn’t working for you, or you are unable to connect to your JupyterLab?

The address is if you are connected over MicroUSB. If you are connected over WiFi, check the IP address or hostname of your Nano and use that instead.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.