Jetson Nano Wifi - USB Adapter

I bought the Edimax EW-7811Un 150Mbps 11n WiFi USB Adapter and find that the wifi connection (bad quality) is on-and-off. Very often, I still need to use the cable for connection.

Can someone suggest a better adapter to use or let me know if I need to do some special setting in Nano to get the adapter performing better?

Thanks
Jimmy

Hi Jimmy, please see this post for a workaround to improve the connection:

https://devtalk.nvidia.com/default/topic/1049303/jetson-nano/jetson-nano-wifi-/post/5329699/#5329699

Hi Dusty,

Per your information, now the wifi adapter works fine.

Thanks a lot
Jimmy

Hi Jimmy… I would recommend going to the Intel 8265 NGFF M.2 Wifi/BT module. It cost me $27.00 on eBay and foil antenna $7.99 on Amazon. The fastest I was getting with the Edimax N150 was 72 Mb/s. I was also getting the dropouts every 5 min, but received the Intel adapter prior to implementing the fix. I now get 650 Mb/s using 5 GHz AC with the Intel adapter and have freed up 2 USB ports without having to use BT dongle and Wifi dongle. I have Gigabit internet (Gigablast). Nice jump in speed for a little money.

TP-LINK TL-WN722N works right out of the box (bought in Europe). It has a descent antenna and solve my problems with bad reception with the Edimax “dongle”. In order to free as many USB-ports as possible I finally ended up buying a M.2 card (AC 8265). The desktop kit with the suffix DTX1 is recommended, it also includes two removable antennas/holders at almost the same price as just the M.2 card.

Thanks for your good information. I am going to buy the Intel 8265 soon.

Be careful with the Intel 8265 card. My Jetson Nano can’t boot after installing one of them. Even I can’t see any logo when I try to boot, only the little green led in the board switches on.

I have two of them. One has this frequent dropout it on nano but the other doesn’t. I didn’t do more testing but I can. Also, this may sound strange, but you could also try another USB port. My mouse stutters on one port but not the other on nano. I may have plugged the second edimax into a different port as well.

I also bought the EW-7811Un 150Mbps and had the same difficulty that has been described. EDiMAX provided
the following links that solved my problem.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1365844

https://github.com/pvaret/rtl8192cu-fixes

Great! Thanks for sharing!

Just bought (Turkey, is probably also valid in Europe) and tried out a TP-LINK TL-WN822N version 5 (antennas on the sides, box, usb type-b mini, version annotated under the box) and a TP-LINK TL-WN823N (dongle-type, no protruding antennas, usb connector annotation reads an FCC version code ending with a V2).

They do work out of the box but have a signal quality problem with the native rtl8xxx driver on the kernel. This driver fixes that problem:

Hi @buraksoner,

I also have the TP-Link TL-WN823N and cannot make it work with the Nano. The SSID of the WiFi is detected but the password is not accepted as correct and it keeps asking for the password. I am of course sure the password is correct.

Can you please confirm that you have just followed the steps in Mange’s repo on a clean install?
Did you perhaps use any other commands?

Hello savvas.argyropoulos,

I’ve followed the exact steps from the website I posted and didn’t run into the problem you’ve described. I suspect your problem could have something to do with the issues described in the following links (if you haven’t checked these already):

http://forums.debian.net/viewtopic.php?f=30&t=142930
(See especially the last two posts in this one)

https://adamscheller.com/systems-administration/rtl8192cu-fix-wifi/

Hope this helps,
Burak

Sorry, forgot to add: I executed those steps in the repo I posted after a clean install, right after the first startup.

Hi Burak,

Thank you for the reply. It still does not work. Just to make sure that we have the same WiFi dongle, can you post the output of

lsusb && lsmod && uname -a

Hello savvas,

I don’t have access to the 823N dongle right now, I use the 822N (since it has the 3dBi antennas, better reception). I had bought the 823N just to try it out to see if it works with the Nano, then I gave it to another colleague. I’ll post the result of those commands if I can get it back but I think we can be sure that we have the same device if yours also reads V2 at the end of the FCC version code (it’s on the USB connector, inscribed on the metal part). If I’m not wrong, that denotes the silicon version from the TP-Link side.

Regards,
Burak

The description has faded out from the metal part, I cannot see it, this is why I asked for the lsusb command output. Please post here if you happen to get it back.

Thanks,
Savvas

Hello Burak,

I finally verified that it is indeed a WN823V2.
Could you please report your kernel version with

uname -r

Also, the last URL you referred me to is about the 8192cu version, which is not related to this WiFi dongle.
Did you install that version as well?
My understanding was that you only installed the driver from Mange’s repo.

Regards,
Savvas

Hello Savvas,

The result of uname -r is

4.9.140-tegra on my machine.

Hope this helps,
Burak

I have the same kernel version. Well, I have given up and ordered an Edimax usb dongle.
Thank you again for the prompt replies.