Jetson nano wifi

I want to know the , kernel driver installation for tplink or edimax USB WiFi adapters…
if anyone have successfully installed…

Edimax worked out of the box. Drivers are already in image, so no need to install anything extra. Pleasant surprise.

1 Like

I use USB wifi with RTL8812BU chip on my jetson nano, there is no driver in image

lsusb
Bus 001 Device 003: ID 0bda:b812 Realtek Semiconductor Corp.

Fortunately I found driver on github:

https://github.com/cilynx/rtl88x2BU_WiFi_linux_v5.3.1_27678.20180430_COEX20180427-5959

It works fine after following “DKMS installation” guidance.

Hi, shankarharan1999

You can try to get the driver from the vendors or the github for your type to see if there is some problem during installation. Feel free to use the wifi device from the Nano support components list.

@li.ngmob0 Thanks a lot I have the same hardware and the drivers from the link you provided works for me too :) I was struggling to find the right driver.

Anyone having an issue with the Edimax Wifi dongle Wifi connections? It seems to hold connection for ~5 minutes or less and then it still shows connected, but the speed drops to 7Mb/s from 72Mb/s and browser comes up with no internet. I tried at home and work with same issue. I also am using a BT dongle. If I close the Wifi connection and reconnect, speed and internet is back to normal for a short time and again it drops to 7Mb/s and lose internet. Annoying when trying to install stuff that needs internet and it hangs during the process.

Deleted.

Typically, if you hover your mouse over the quote icon in the upper right corner of one of your existing posts you will see other icons pop up. Usually I mention the paper clip icon for attaching files to an existing post…but the pencil icon does let you edit a post (you just won’t see the edit icon unless your mouse hovers over the quote).

@Linuxdev… fixed… Thanks! Still having weird issue where Wifi drops to 7Mb/s and says no internet access and I have to disconnect and reconnect to get back to speed.

We are looking into this, will let you know what we find out.

@Vasr

You can try to turn off the power_save mode to see if it could help.

sudo iw dev wlan0 set power_save off

@alanz

Thank you. Newbie question… which file do I edit to add/update the code you provided? I am a bit new to Linux.

Open a new terminal (Ctrl+Alt+T) and run the command in the terminal window.

I tried this command too, and it seems to improve the connectivity. We will keep looking into it. Thanks @alanz!

@dusty_nv
@alanz

I turned off the power_save mode per your instructions, but still get only a minute or so… sometimes 5 minutes before connection drops from 72Mb/s to 7Mb/s and no internet connectivity. Kind of frustrating trying to install an app when it loses connection to the repository.

I am using the Edimax EW-7811UN Wifi adapter that is recommended in the Nano supported component list. Does the Intel 8265NGW M.2 Wifi card exhibit the same behavior? I may purchase the M.2 card if it works better.

Hi, Vasr

This is the log I have catched from Intel 8265 NGW. You can monitor the ‘Signal level’ and the channel your USB WIFI working with. For USB WIFI, it first go through the USB interface, then transfer data via the air. So both usb and signal/channel will give some abnormal behavior. If the Signal level is weak it will disconnect from the AP port. In the same time check the kernel logs from the dmesg command, if there is a disconnection there must be some information there indicating if it’s an error or just lost the signals. The Dropped packets and errors number should also give you some useful information.

sudo ifconfig wlan0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.102  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::19c7:7098:8883:8cb  prefixlen 64  scopeid 0x20<link>
        ether 48:f1:7f:74:0c:7f  txqueuelen 1000  (Ethernet)
        RX packets 791  bytes 101789 (101.7 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 759  bytes 102963 (102.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Because I don’t have a Edimax EW-7811UN Wifi adapter on my hand. Just give some information hope could help.
‘Signal level=-27 dBm’ a good quality for the signal with channel 10.

jetbot@jetbot:~$ iwlist wlan0   scanning
wlan0     Scan completed :
          Cell 01 - Address: B4:0F:3B:2C:75:91
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=70/70  Signal level=-27 dBm  
                    Encryption key:on
                    ESSID:"vvt_2.4G"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000002a85bae18d
                    Extra: Last beacon: 410572ms ago
                    IE: Unknown: 00087676745F322E3447
                    IE: Unknown: 010882848B96A4B0C8EC
                    IE: Unknown: 03010A
                    IE: Unknown: 050400010000
                    IE: Unknown: 2A0100
                    IE: Unknown: 32048C9298E0
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 46053208010000
                    IE: Unknown: 2D1ABC091BFFFF000001000000000000000000000000000000000000
                    IE: Unknown: 3D160A080400000000000000000000000000000000000000
                    IE: Unknown: 7F080400000000000040
                    IE: Unknown: DD090010180200000C0000
                    IE: Unknown: DD180050F20201010C0003A4000027A4000042435E0062322F00
[   11.721388] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8265-25.ucode failed with error -2
[   11.742510] r8168: eth0: link up
[   11.750790] iwlwifi 0000:01:00.0: Falling back to user helper
[   11.762754] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   14.566553] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8265-24.ucode failed with error -2
[   14.576767] iwlwifi 0000:01:00.0: Falling back to user helper
[   14.842650] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8265-23.ucode failed with error -2
[   14.870504] iwlwifi 0000:01:00.0: Falling back to user helper
[   15.024432] iwlwifi 0000:01:00.0: loaded firmware version 22.391740.0 op_mode iwlmvm
[   15.100823] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   15.100836] Bluetooth: BNEP socket layer initialized
[   15.167227] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
[   15.170391] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   15.171862] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   15.297263] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   15.298668] thermal thermal_zone6: failed to read out thermal zone (-5)
[   15.311316] thermal thermal_zone6: Registering thermal zone thermal_zone6 for type iwlwifi
[   15.818416] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   15.820965] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   15.821553] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   15.954672] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   15.955554] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   16.026791] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   16.162741] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   18.956166] fuse init (API version 7.26)
[   20.613300] wlan0: authenticate with b4:0f:3b:2c:75:91
[   20.640822] wlan0: send auth to b4:0f:3b:2c:75:91 (try 1/3)
[   20.656023] wlan0: authenticated
[   20.659020] wlan0: associate with b4:0f:3b:2c:75:91 (try 1/3)
[   20.704131] wlan0: RX AssocResp from b4:0f:3b:2c:75:91 (capab=0x1411 status=0 aid=1)
[   20.709768] wlan0: associated

BTW, run the jetson_clocks command is another option worth to try.

You can use command below to check your wifi environment.

nmcli device wifi list

Make sure your wifi router works fine

@alanz and @li.ngmob0

Thanks for the info. I tried Jetson_clocks briefly late yesterday, but seemed better. Will need to check again today to verify. Signal strength at home and work are strong so no issues with that piece. Plugging into Ethernet directly works fine (but no Ethernet port lights which is apparently a Nano bug). I most likely will order the 8265 NGW.

@alanz … which antenna are you using with your 8265 NGW?

Thanks again.

@vasr

There is a BOM list for Jetbot.

antenna

https://www.arrow.com/en/products/2042811100/molex

Hi, I am using the same USB wifi adapter Edimax EW-7811UN Wifi adapter. I have the same issue and the wifi keep consistently get deauthenticated and need to reconnect to the network quite often.

Please kindly find the info below:

dmesg output:

[   31.690934] tegradc tegradc.0: unblank
[   31.690944] tegradc tegradc.1: blank - powerdown
[ 1385.000408] wlan0: deauthenticating from 60:a4:4c:66:b8:2f by local choice (Reason: 3=DEAUTH_LEAVING)
[ 1387.173242] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 1387.195452] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 1387.297959] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 1387.359442] wlan0: authenticated
[ 1387.362087] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 1387.399270] wlan0: RX AssocResp from 60:a4:4c:66:b8:2f (capab=0x411 status=0 aid=5)
[ 1387.408158] wlan0: associated
[ 2896.678552] wlan0: deauthenticating from 60:a4:4c:66:b8:2f by local choice (Reason: 3=DEAUTH_LEAVING)
[ 2898.733466] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 2898.758672] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 2898.862788] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 2898.899651] wlan0: authenticated
[ 2898.902740] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 2898.907560] wlan0: RX AssocResp from 60:a4:4c:66:b8:2f (capab=0x411 status=0 aid=5)
[ 2898.912125] wlan0: associated
[ 3488.115940] wlan0: deauthenticating from 60:a4:4c:66:b8:2f by local choice (Reason: 3=DEAUTH_LEAVING)
[ 3488.237926] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 3489.255011] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 3489.267260] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 3489.291566] wlan0: authenticated
[ 3489.295277] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 3489.338120] wlan0: RX AssocResp from 60:a4:4c:66:b8:2f (capab=0x411 status=0 aid=5)
[ 3489.348665] wlan0: associated
[ 3489.377332] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 4392.111762] wlan0: deauthenticating from 60:a4:4c:66:b8:2f by local choice (Reason: 3=DEAUTH_LEAVING)
[ 4394.241951] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4394.261431] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4394.363553] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4394.467699] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4394.571569] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4395.698711] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4395.715845] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4395.715904] wlan0: authenticated
[ 4395.719734] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 4395.823585] wlan0: associate with 60:a4:4c:66:b8:2f (try 2/3)
[ 4395.927557] wlan0: associate with 60:a4:4c:66:b8:2f (try 3/3)
[ 4396.031538] wlan0: association with 60:a4:4c:66:b8:2f timed out
[ 4397.527130] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4397.549818] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4397.651580] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4397.755819] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4397.859976] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4399.882807] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4399.904950] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4400.007595] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4400.111573] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4400.215568] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4410.226147] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4410.240353] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4410.308822] wlan0: authenticated
[ 4410.311338] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 4410.415253] wlan0: associate with 60:a4:4c:66:b8:2f (try 2/3)
[ 4410.519235] wlan0: associate with 60:a4:4c:66:b8:2f (try 3/3)
[ 4410.623319] wlan0: association with 60:a4:4c:66:b8:2f timed out
[ 4418.060414] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4418.084736] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4418.187087] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4418.291119] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4418.395129] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4426.019549] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4428.090249] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4428.112404] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4428.214874] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4428.319254] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4428.423141] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4439.461238] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4439.480939] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4439.582921] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4439.686713] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4439.790653] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4451.061026] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4452.128811] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4452.140305] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4452.242757] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4452.346570] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4452.450595] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4466.877784] rtl8192cu: MAC auto ON okay!
[ 4466.912974] rtl8192cu: Tx queue select: 0x05
[ 4467.334543] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4467.403519] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4468.461487] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4468.473844] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4468.574143] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4468.678154] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4468.708564] wlan0: authenticated
[ 4468.714157] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 4468.818576] wlan0: associate with 60:a4:4c:66:b8:2f (try 2/3)
[ 4468.922954] wlan0: associate with 60:a4:4c:66:b8:2f (try 3/3)
[ 4469.026403] wlan0: association with 60:a4:4c:66:b8:2f timed out
[ 4470.140790] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4470.160482] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4470.262273] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4470.366248] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4470.470144] wlan0: authentication with 60:a4:4c:66:b8:2f timed out
[ 4472.011558] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4472.032107] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4472.032202] wlan0: authenticated
[ 4472.034042] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 4472.138151] wlan0: associate with 60:a4:4c:66:b8:2f (try 2/3)
[ 4472.242259] wlan0: associate with 60:a4:4c:66:b8:2f (try 3/3)
[ 4472.345997] wlan0: association with 60:a4:4c:66:b8:2f timed out
[ 4474.382420] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 4474.402706] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 4474.505986] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 4474.610017] wlan0: send auth to 60:a4:4c:66:b8:2f (try 3/3)
[ 4474.677600] wlan0: authenticated
[ 4474.682142] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 4474.786078] wlan0: associate with 60:a4:4c:66:b8:2f (try 2/3)
[ 4474.807421] wlan0: RX AssocResp from 60:a4:4c:66:b8:2f (capab=0x411 status=0 aid=5)
[ 4474.809409] wlan0: associated
[ 4476.114587] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 4581.826003] nvgpu: 57000000.gpu             railgate_enable_store:343  [INFO]  railgate is disabled.
[ 6476.105479] wlan0: deauthenticating from 60:a4:4c:66:b8:2f by local choice (Reason: 3=DEAUTH_LEAVING)
[ 6478.146514] wlan0: authenticate with 60:a4:4c:66:b8:2f
[ 6478.168586] wlan0: send auth to 60:a4:4c:66:b8:2f (try 1/3)
[ 6478.268872] wlan0: send auth to 60:a4:4c:66:b8:2f (try 2/3)
[ 6478.364081] wlan0: authenticated
[ 6478.364877] wlan0: associate with 60:a4:4c:66:b8:2f (try 1/3)
[ 6478.422020] wlan0: RX AssocResp from 60:a4:4c:66:b8:2f (capab=0x411 status=0 aid=5)
[ 6478.423989] wlan0: associated

When wifi is working:

fei@fei-desktop:/opt/nvidia/jetson-gpio/lib/python$ nmcli device wifi list
IN-USE  SSID              MODE   CHAN  RATE        SIGNAL  BARS  SECURITY  
        A                 Infra  11    130 Mbit/s  100     ▂▄▆█  WPA2      
        B                 Infra  6     270 Mbit/s  84      ▂▄▆█  WPA1 WPA2 
*       Home              Infra  11    130 Mbit/s  58      ▂▄▆_  WPA2      
        C                 Infra  1     130 Mbit/s  54      ▂▄__  WPA1 WPA2 
        D                 Infra  10    270 Mbit/s  54      ▂▄__  WPA2      
        E                 Infra  2     270 Mbit/s  44      ▂▄__  WPA2      
        F                 Infra  10    270 Mbit/s  44      ▂▄__  WPA1 WPA2

When wifi is NOT working: (All other existing network are gone)

IN-USE  SSID  MODE   CHAN  RATE        SIGNAL  BARS  SECURITY 
*       Home  Infra  11    130 Mbit/s  76      ▂▄▆_  WPA2

ifconfig output:

fei@fei-desktop:/opt/nvidia/jetson-gpio/lib/python$ ifconfig wlan0
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.250  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::5c01:747f:4180:5193  prefixlen 64  scopeid 0x20<link>
        ether 74:da:38:ee:c2:92  txqueuelen 1000  (Ethernet)
        RX packets 51485  bytes 40396191 (40.3 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 43591  bytes 6656519 (6.6 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig output:

fei@fei-desktop:/opt/nvidia/jetson-gpio/lib/python$ iwconfig
lo        no wireless extensions.

usb0      no wireless extensions.

l4tbr0    no wireless extensions.

dummy0    no wireless extensions.

wlan0     IEEE 802.11  ESSID:"Home"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 60:A4:4C:66:B8:2F   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:124   Missed beacon:0

eth0      no wireless extensions.

rndis0    no wireless extensions.

nmcli output:

fei@fei-desktop:/opt/nvidia/jetson-gpio/samples$ nmcli connection show
NAME                UUID                                  TYPE      DEVICE 
Home                6e4112e6-6c94-4b74-8919-8fbbba8681a3  wifi      wlan0  
l4tbr0              6310116d-0cac-4ae7-942b-463e5794b104  bridge    l4tbr0 
Home 1              ffd9e5aa-cbf5-4d6c-8177-50129e47b997  wifi      --     
Wired connection 1  6bcc9f4a-9886-3175-9b01-fc283fb21ad7  ethernet  --

Hope this can be solved soon.

Problem solved. It is due to a buggy driver. Try the following command and wifi seems to work well without disconnecting.

echo "blacklist rtl8192cu" | sudo tee -a /etc/modprobe.d/blacklist.conf