Jetson not booting up : Orin Nano 8G A78AE v8.2

I have successfully used balenaEtcher to flash the micro SD card, I tried on both a 512GB and 64GB micro sd card

I am able to see the splash screen and get into the bios

But when it tries to attempt direct boot, its fan will stop and I loose all video output.

Flash with SDK Manager.

Hi Dave,
How do I go about that?

I had previously went to the following hyperlink, downloaded the “JETSON ORIN NANO DEVELOPER KIT”. Once I extracted the zip file, I used BalenaEtcher to make the bootable microSD card using the provided image file ‘sd-blob.img’.

I mean this one:

Does this flash the Nano Development board itself, or do I still need the MicroSD card that was flashed using the BalenaEtcher utility?

Of course SD card has to be plugged in.

Hello Dave,
I installed the SDK manager on my Ubuntu laptop, and have the jetson connected to my pc via a USB C to USB A cable.

However, SDK manager is still not able to detect my device.

Furthermore, the box my NVIDIA ORIN NANO came in just says that, it does not specify NX.

How do I know what model mine is? According to the underside of the box my Jetson the model number is P3766 which according to Google is the NX model, but wanted to confirm that it in fact is the NX model opposed to a different variant of the Nano Orin.

The other specs on the box list that this device has 8GB 128 bit LPDDR5 with 6-Core arm Cortex A78AE v8.2

Thank you by the way for all of your assistance thus far

Also note, my laptop does not have a USB C female port, just USB type A. The cable is able to be used with connection to my Samsung phone for USB debugging. I am assuming it can also connect to the Jetson.

If not, can you provide alternate ways to communicate with this Jetson device?

Thank you

I was able to provide the Jetson Nano an IPv4 address via system setup using the esc key and am able to ping its IPv4 address since both my laptop and jetson are connected via a l2 switch.

If this helps

Do you know you have to use a jumper?

Where is the jumper on my device? I am not seeing it?

Like mentioned in this post:

The device can only be flashed when it goes into force recovery mode with FC REC and GND shortened.
Or a dupont line should also do it.

I don’t really know what you mean with this.
Then what is your current issue?


In short, I did the following

  • Formatted microSD card
  • Flashed microSD card using BalenaEtcher and the .img file from the getting started page
  • Inserted the microSD card
  • Connected, USB Keyboard, Display Port connection and power
  • Watched the NVIDIA splash screen pop up
  • Then after a few seconds the fan stopped spinning and my display went to sleep

I am able to boot it up into system setup (bios)

but cannot proceed further

Then re-flash with SDK Manager following what I said here.

SDK Manager cannot find the board, how do I flash it?

I already told you here…
Or you don’t know what I’m saying?

I see what you are referring to, I found the pins you mentioned. Did not see them initially.

I did that and its flashing as we speak. I was able to get the board to be recognized.

Thank you

The screenshot doesn’t help anything.