Jetson Orin long boot time

I have a Jetson Orin Dev Kit on Jetpack 5.0.1 Rev1 and am having some issues with it. The boot time is around 5 min from when I apply power. I can see the screen come to life and notice the jetson is awake. At the same time the console output tells me its started booting but then takes 5 min to get to the login screen.

Attached are the console outputs from the bootup process.

I have flashed it a number of times now to try to address the issue. I have cleaned out all the downloaded files and reflashed it to see if a corrupt download but still has the same issue.

The bootup goes as follows:

Jetson UEFI firmware (version 1.0-d7fb19b built on 2022-08-10T20:18:13-07:00)

5 min later

e[2Je[04De[=3he[2Je[09D** WARNING: Test Key is used. **
L4TLauncher: Attempting GRUB Boot
L4TLauncher: Attempting Direct Boot
EFI stub: Booting Linux Kernel…
EFI stub: Using DTB from configuration table
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path …

If I power on the jetson and instead of waiting I hit the reboot button it will start up in a very short time.
jetson orin bad (72.5 KB)
jetson orin reboot (72.5 KB)

Are we talking about jetpack5.0.2 or jetpack5.0.1? Could you upgrade to latest version first?

Sorry about that, I mean 5.0.2.

I have tried reflashing the jetson with a freshly cleared and installed sdk, still the same issue.

Please share log and timstamp info.

booting g.txt (120.5 KB)
Here is the dump with a time stamp. You can see 15:59:50 then there is nothing till 16:03:55.

  1. You need to build the UEFI binary and reflash the one with debug build. Otherwise, default UEFI won’t print any log. I won’t know what is happening in those blanked log either.
  1. If you have any peripherals, you can also remove it from devkit too and see if which one is making difference.

I have reflashed the jetson with a new UEFI binary built on the same machine.

booting2.txt (163.4 KB)

It still has the same issue it seems but with even more logs.

Yes, of course it would have same issue. We are just enabling more log but didn’t do anything special…

Are you sure this is jetson Orin devkit but not some custom carrier board?

It shouldn’t be, this was ordered as a dev kit from Arrow. We haven’t changed out the sub board, just added a SSD and a PCIE usb card that pulls its power from the 5v pin.


I asked this in previous comment before. Did you try it or not?

If you have any peripherals, you can also remove it from devkit too and see if which one is making difference.

I have tried this, after removing the SSD and PCIE card I found no change. Because there was no change I reinstalled them as they are needed for the application we want to use the jetson orin for.

We have the same setup on a handful of jetson xaviers and are not having this issue.


Could you remove them again and share me the UEFI log again?

I saw a weird 2 min delays here but not usre which interface is causing it. Feels like a usb device.

[12:58:47.579968 0.004377] PROGRESS CODE: V02020006 I0
[12:58:47.832220 0.252250] XHCI: Don't support multi-TT feature for Hub now. (force to disable MTT)
[12:58:48.351288 0.519068] PROGRESS CODE: V02020006 I0
[12:58:48.571583 0.220295] PROGRESS CODE: V02020006 I0
[12:58:48.785231 0.213648] SNP:PHY:  () Failed to configure Phy
[12:58:48.787054 0.001827] DeviceDiscoveryBindingStart, driver returned Device Error to start notification
[12:58:48.808551 0.021496] PROGRESS CODE: V02010000 I0
[12:58:48.809413 0.000863] PROGRESS CODE: V02010004 I0
[12:58:48.814372 0.004958] PROGRESS CODE: V02010004 I0
[12:58:48.815486 0.001114] PROGRESS CODE: V02010004 I0
[12:58:48.817089 0.001603] PROGRESS CODE: V02010004 I0
[12:58:48.819793 0.002705] PROGRESS CODE: V02010004 I0
[12:58:48.820292 0.000499] PROGRESS CODE: V02010004 I0
[12:58:48.825446 0.005153] PROGRESS CODE: V02010004 I0
[12:58:48.825937 0.000492] PROGRESS CODE: V02010004 I0
[12:58:48.830739 0.004802] PROGRESS CODE: V02010000 I0
[12:58:48.831283 0.000545] PROGRESS CODE: V02010004 I0
[12:58:48.836355 0.005071] PROGRESS CODE: V02010004 I0
[12:58:48.836972 0.000618] PROGRESS CODE: V02010004 I0
[12:58:48.842248 0.005275] PROGRESS CODE: V02010004 I0
[12:58:48.842863 0.000616] PROGRESS CODE: V02010004 I0
[12:58:48.843501 0.000638] PROGRESS CODE: V02010004 I0
[12:58:48.847727 0.004225] PROGRESS CODE: V02010004 I0
[12:58:48.848800 0.001073] PROGRESS CODE: V02010004 I0
[13:00:49.096940 120.248137] ERROR: C80000002:V02070005 I0 5BE3BDF4-53CF-46A3-A6A9-73C34A6E5EE3
[13:00:49.112832 0.015892] PROGRESS CODE: V02010000 I0

Also, could you try to dump the log earlier… Your log is truncated… I don’t see the ful UEFI log…

When compiling UEFI, I found that the command was not found: stuart_ Update, do you know which package this is in?

edk2-nvidia/Platform/NVIDIA/Jetson$ ./
nvidia: building from workspace rooted at: /home/lulu/works/project/adu506/orin/uefi
nvidia: found command: python3.
nvidia: found command: virtualenv.
nvidia: found command: mono.
nvidia: found command: aarch64-linux-gnu-gcc.
nvidia: Activating Python virtual environment.
nvidia: Building from tarball
nvidia: Updating build environment (edk2-nvidia/Platform/NVIDIA/Jetson/
edk2-nvidia/Silicon/NVIDIA/scripts/ line 47: stuart_update: command not found

have already been solved

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.