Jetson AGX Orin Long Boot Time


I using Jetson Agx Orin 64 Gb with Forecr DSBOARD_Agx Rev1.1 carrier board.
Ubuntu 20.04.
Kernel Version: 5.10.104
l4t: 35.3.1
Jet-pack 5.1.1

My Problem is that, the boot time is longer than 80 seconds. I need to decrease it to lower than 60sec.
I Tried to disable some service or kernel modules. also I change the timeout of extlinux.conf but these are dosen’t chage anything.

When I plug the power, after a 30sec. boot options menu screen appeared. This 30sec never change.
when pass the boot options menu, after nearly 50 sec NVIDIA logo appeared and Desktop open. But also during all these processes, I don’t see anything in the monitor except boot options menu and nvidia logo.

Hi serdar.anil33,

Please provide the full serial console log with timestamp enabled for further check.

Could you share what boot option menu do you see?
You should not enter any UEFI menu or boot option menu if you do not have any input during boot up.


I connect the debug port, I can’t see anything during the first 25 - 30 second then the boot options menu login appeared. The menu I mean that the key interrupt waiting screen. (screen waits 5 seconds to press esc or F11 to open boot options menu.) After this screen boot is starting directly and then I can recieve console outputs from debug port.

I don’t have any problem about the term after the boot options screen. But I don’t understand the term of first 25 - 30 seconds that starting from power plugging to the boot options menu.

I would need to check your full serial console log with timestamp enabled.
There should be MB1/MB2 boot up process before boot menu from UEFI.

Hello, Thanks for reply

I Think this is the what you want but i am not sure about it.

boot_log.txt (101.7 KB)

I take a log file from gtkterm by using the debug port.

Yes, it is the serial console log what I want to check.
Could you enable the timestamp during capturing these logs so that I could know where it takes time for long boot up?

ÿäE/TC:?? 00 get_rpc_alloc_res:645 RPC allocation failed. Non-secure world result: ret=0xffff0000 ret_origin=0
E/LD:   init_elf:486 sys_open_ta_bin(bc50d971-d4c9-42c4-82cb-343fb7f37896)
E/TC:?? 00 ldelf_init_with_ldelf:131 ldelf failed with res: 0xffff000c

Does it get stuck when it print these messages in UEFI?

How Can I Enable Timestamp? Can you inform me about it? I reseached and I tried something but I cannot do it.

It depends on the serial application.
I’m using minicom so I could press CTRL + A and then N to activate the timestamp.

Here it is. I hope that is the what you want. Thanks for help.

boot_log.txt (140.2 KB)

[2023-09-26 10:29:22] 
[2023-09-26 10:29:40] Jetson UEFI firmware (version 4.1-33958178 built on 2023-08-01T19:34:02+00:00)

Does the boot time you want to optimize between 10:29:22-10:29:40?
If so, you could build debug binary to enable more logs in UEFI.
Or you could just verify with the latest JP5.1.2(R35.4.1), there should be several fixes included.

Sorry I forgot the inform yo but I already update Jetpack 5.1.2. I tried disable some modules and service but it does not change anything. When I use systemd-analyze it seems to be shorten but when I start chronometer from the start, I measure the same booting time. Actually I don’t understand this. That situation gives me an abnormal impression

So I need to decrease boot time under the 60sec. due to the work of my project. That’s why I need to make all the optimizations I can. (I use the graphical UI so I cant use multi user target mode)

It seems something wrong in your UEFI on the custom carrier board.
Could you help to update the debug UEFI binary to enable more debug messages?

You could refer to the following instruction to build UEFI binary.
Build without docker · NVIDIA/edk2-nvidia Wiki · GitHub

$ edkrepo clone nvidia-uefi-r35.4.1 NVIDIA-Platforms r35.4.1

it built successfully i think. but I will ad the build log if you want to check it.
BUILDLOG_Jetson.txt (4.8 MB)

Now What I need to do? I think there is no change in the boot logs.

Sorry, I made a msitake. I clone with main but now I rebuiild for nvidia-uefi-r35.4.1
Now I share the new debug log.
BUILDLOG_Jetson.txt (4.4 MB)

So how can i flash it?

Please replace the <Linux_for_Tegra>/bootloader/uefi_jetson.bin with uefi_Jetson_DEBUG.bin you just built.
and re-flash the board to apply.

OK! Thanks for your help again. Here it is.

boot_debug_log.txt (291.1 KB)

By the way can I custimize boot logo or uefi options screen by using this edk2 repo? Also I want to skip opening logo and boot option screen.