Jetson orin nano Cuda Cudnn torch torchauido torchvision

Hello,

I have a code that I’m trying to run using Nvidia Jetson Orin Nano. The code runs, but it’s quite slow because it runs on the CPU. Therefore, I need to activate CUDA. First, I want to do this process on an Ubuntu computer with an Intel processor. For this reason, I want to use CUDA 12 or higher, supported by Jetpack 6 and above.

I need information on which versions of CUDA 12 and above are compatible with Torch, TorchAudio, and TorchVision. I tried with Torch 2.2 but was unsuccessful. When I check the version with nvcc --version, I see CUDA 12.2. Similarly, when I try the following Python code, it returns versions but says CUDA is not enabled:

Please inform me of the Torch and the necessary library versions compatible with any version of CUDA 12 or higher, working on Ubuntu 22.04 with x86_arm64 architecture.

Note: I have also downloaded these libraries via pip3 and conda (miniconda3), but the result hasn’t changed. When providing the versions, I kindly request you to share how I should download them and, if possible, terminal commands.

Best Regards,
Good Work!

import torch

# Check if CUDA is enabled
if torch.cuda.is_available():
    print("CUDA is enabled.")
else:
    print("CUDA is not enabled.")

# Print Torch and TorchVision versions
print("Torch version:", torch.__version__)
print("TorchVision version:", torch.__version__)

# Print TorchAudio version
import torchaudio
print("TorchAudio version:", torchaudio.__version__)

Hello,

Thanks for visiting the forums. Your topic will be best served in the Jetson category.

I will move this post over for visibility.

Cheers,
Tom

1 Like

Hi,

How do you install PyTorch?
We have some prebuilt packages for JetPack 6 and you can install them with the below instructions:

We also have a container with Torch-related libraries installed.
You can also give it a check (l4t-ml:r36.2.0-py3):

Thanks.

jetson orin nano problems.pdf (184.1 KB)

Hello Sir,

Thank you for your answer . please review the documentation of almost everything I’ve tried so far.
Best Regards

Hi,

Thanks for the detailed pdf.

The environment looks good to us.
But the problem comes from the PyTorch/TorchVision/TorchAudio installation.

The package from pip3 only builds with CPU support.
You can surely build it from the source (like you try in the pdf) but it will be easier to install our prebuilt.

$ sudo apt-get -y install python3-pip libopenblas-dev
$ python3 -m pip install --upgrade pip; python3 -m pip install numpy==’1.26.1’ python3 -m pip install --no-cache https://developer.download.nvidia.cn/compute/redist/jp/v60dp/pytorch/torch-2.3.0a0+40ec155e58.nv24.03.13384722-cp310-cp310-linux_aarch64.whl

Please check the CUDA support again after running the above command.
Thanks.

hello again sir ,
i did what you say first off all i run this command
and then pip3 uninstall torch torchvision torchaudio after that i run the first command again and this one
$ sudo apt-get -y install python3-pip libopenblas-dev
$ python3 -m pip install --upgrade pip; python3 -m pip install numpy==’1.26.1’ python3 -m pip install --no-cache https://developer.download.nvidia.cn/compute/redist/jp/v60dp/pytorch/torch-2.3.0a0+40ec155e58.nv24.03.13384722-cp310-cp310-linux_aarch64.whl

lastly ı run the pip3 install torch torchaudio torchvision and pip install torch torchaudio torchvision



but nothings change

by the way i upgrade cudnn 9.1.0

Hi,

The package is built with the default JetPack library.
So you will need to use the default version.

Thanks.

Yes, I was already using 8.9.1, which was coming as default, this is also seen in the previous screenshots, but when it did not work, when I downloaded cudnn for the system and cuda 12, 9.1.0 came up, thinking that maybe it would work, I downloaded it again, but this does not seem to solve my problem, because if it did, thousands of thousands of times above were downloaded. I think it would solve it if I tried it. Also, why can’t I see anything when I type nvdia-smi? Are my driver packages missing? If so, what should I download for the Jetson Orin Nano 8 GB Developer Kit?

Hi,

Only CUDA has Jetson-compatible packages on the website.
For other libraries, please use the package from JetPack which can be found below (JetPack apt link):
https://repo.download.nvidia.com/jetson/

Could you reset the system and install the PyTorch package shared above?
Different library versions might cause some unexpected compatibility issues.
Setting the environment with JetPack and installing our PyTorch is the way we recommended and verified.

Jetson is an iGPU system so the driver is integrated into the OS.
It doesn’t have a standalone GPU driver so it won’t show on the nvidia-smi.

Thanks.

ı solved with dusty 's jetpack 6 .whl file thank you so much , but i guess this files helps me