Jetson TK1: Newer version of nvidia driver for xorg required

Dear Sirs,

is it posssible to get either

  • the source code for the driver "/usr/lib/xorg/modules/drivers/",
  • the source code for the extension "/usr/lib/xorg/modules/extensions/"


  • a newer binaries with ABI version >= 24.0 of these files

for Jetson TK1 with L4T?

The background: Newer versions of Xorg require ABI >= 24.x

Thanks in advance

Hi MickPF,

The X ABI version in current Jetson TK1 is 19, and we don’t support newer version.
Could we know why you need a newer binaries with ABI version >= 24.0?



about a year ago I used successfully archlinux (with MATE-Desktop) on my Jetson-TK1, because I don’t like ubuntu linux. Sometime I replaced it by ubuntu-16.04 (ubuntu-mate), because I had some problems with a software.

Now I want/must change back to archlinux, but can’t get X running, caused by older ABI of files mentioned above.
Starting X server displays two errors:

  • "Incompatible ABI" (X server <-->
  • "Error allocating NVIDIA ErrorHandler"

I can turn off the first one by

  • IgnoreABI = true

in xorg.conf,
but the second error is fatal.

It is not posssible, to “downgrade” the archlinux, and I don’t have any backups of archlinux for Jetson anymore.

That’s I’m looking for newer version if these files!

Kind Regards

Hi MickPF,

Sorry to update you that ABI 19 is the highest currently supported ABI version on R21.5, the latest release for Jetson TK1.



does it mean, that the NVIDIA’s project Jetson-TK1 is DEAD for NVIDIA itself?

What’s about source code for these files? I’d compile them by my self…

Kind Regards,


Hi MichPF,

Any updates about this issue?


Hello Mipsan,

of course NOT. The larger the manufacturer, the less you can achieve with it!

I’m very unhappy about that…
Because I’ve to use the very old Ubuntu 14.04 and can’t update to a newer linux…


Release R21.6 did just come out, and I think it may support more X11 ABIs…don’t know if it covers your case or not, but do look at R21.6.

Note that if you are in need of a version for a newer CUDA it won’t be possible…this is a 32-bit/64-bit issue and newer CUDA does not support 32-bit regardless of ABI.


I’m truly afraid of hearing your news.

Though I do not think R21.6 covers this issue, I will test it.




Jetson-TK1 returns as follow with R21.6;

This server has a video driver ABI version of 23.0 that is not
supported by this NVIDIA driver. Please check for driver updates or downgrade to an X
server with a supported driver ABI.

Which software/libraries were you using at the time of that message (e.g.,

Something I’m looking at are the release notes found here:
Or specifically:–Sj7N_r38Rzd1TUI_EEfEcWoSTt13NU_Fm1L3mJ9yogIe4lVN7J0PrD-eyw5hcS8ZdpXHxn9jU5BpNW577bhwbM7kT5ZJYzlwXfOILVUGA2lIxthddDUS-oB_XpTIGTR-bBEQJDmg

Within those release notes is this:

[1568275] Adds support for ABI 17, 18 and 19

Is that error message from a different NVIDIA driver, or from the supplied driver with a new Xorg? I’m wondering what it is which requires ABI 23, and which parts of the system are customized versus stock.