Jetson TK1 no output (even after reflashing L4T)

I have been using my Jetson TK1 board for the past few weeks with minimal problems. However, I recently turned on the board and even though everything powered on, there was no output from the HDMI. I tried completely reflashing L4T from scratch, but the problem persisted even after that. I know the jetson is running as the power light is on, and any devices that are plugged in (camera, usb, mouse) show the connected light on them. Is there a way to fix the output issue?

Do you have ssh or serial console to work with? Typically it is just a video configuration issue…having access would help in figuring it out.

We don’t have either of those, are there any other options?

If you can’t access the Jetson there isn’t much you can do. Maybe try CTRL-ALT-F2 and see if a console shows up…it uses different video configuration. If you get a USB serial UART to DB-9 connector (get the right half) you’d be in far better shape to debug.

We don’t have the ability to really buy anything. We tried using several different cables and monitors but it doesn’t work. It was working fine before so I’m confused what could have possibly changed. We need a replacement ASAP, so I was wondering how we could do this.

RMA instructions are near the top of this:
https://devtalk.nvidia.com/default/topic/793798/embedded-systems/some-jetson-web-links/

Something to think about…I don’t know if this applies to your case…is that only EDID modes are supported. Those modes are queried from your monitor via the DDC wire…this wire does not exist in older 15-pin D-Sub VGA, so if you have any adapter for this, then it guarantees inability to query the monitor.

HDMI is hot plug. So you can remove and re-insert HDMI at any time and it should in theory do the right thing. If it happens that the mode was set using some supported monitor and and mode, then unplugging it and plugging in a VGA monitor would not trigger mode change…if the mode happened to work with that other monitor, then it would work…until something changes the mode. You’d end up having to plug the original working monitor back in, unplugging it, and then plugging the VGA monitor in.

Not every EDID mode is supported. If you use a monitor with no known supported modes, then it is more or less the same as plugging in a VGA monitor and hoping a previous mode works. As soon as something changes the mode the monitor would stop working (unless you got lucky).

If you have any kind of wired network you can reach it with you can work with that…no access is hard to work with.

I do have a wired network, but the Jetson doesn’t seem to be open to ssh for some reason. I also dont have a serial com wire, so I have no other way to access it. My keyboard works with it (the connection light is green) but i dont know how much I can do without actually seeing anything on the screen. I have a project deadline coming up in a week, and the TK1 was our main processor. Is there anyway we could get a replacement during this timeframe (it came with a 1-year warranty I think)

Thanks in advance

I don’t know about emergency replacements…someone else may have an idea.

Note that if you share the Jetson and a different monitor is used, then this might be what changed (because the EDID would change). If this is the case, then finding the monitor which worked would probably do the job again.

Does your router show the Jetson requesting an IP address? Do you see a text mode console if you hit CTRL-ALT-F2?