Jetson TX1 Wifi Speed and Latency


For reference I am building a robot with the TX1. For the most paart the system is autonomous but I do need to send start commands and receive system information back for troubleshooting. The biggest piece of data I need back is a video stream which I’d like to be very low latency. Quality isn’t a huge concern.

I have been seeing very long ping times to both of my TX1’s. They are also cyclical, meaning it start around 60ms then climb to 120ms over the course of 5 pings and then drop down to 60 again and repeats. I’ve been running various tests and I think I have a theory. When I initiate the ping from the TX1 to something else the ping time is a steady 15ms, so I think that when I ping the TX1 it is shutting down some hardware in between pings in order to save power. But when I initiate the ping from the TX1 it keeps the hardware powered.

Can someone from NVIDIA confirm of dispel if this happens. Then I can start approaching a fix to this.

Hi shomakerlevy9,

Sorry for the late reply. What is your wifi operating channel?

Hi WayneWWW,

Our router is operating on the 2.462 GHz channel (Channel 11) and 5.180 GHz (Channel 36)

I’m connected to the 5.180 GHz currently but its worth noting that we have smart connect enabled, so that might be switching me from one to the other.

Channel 11 has no other networks on it in my area
Channel 36 has two other network

My current theory it that I’m seeing multiple issues and one may be causing the other. For instance if the hardware on the tx1 is powering down and causing higher latency, the router could be misinterpreting that as high network traffic and switching me to the other channel.

I’m interested to hear your opinion.

hi shomakerlevy9,

I suffer unstable latency as well. This issue is under investigation.

For you reference I let a ping run for a couple minutes and then plotted the latency. You can see that their is definitely a pattern going on here where it increases steadily for 4 or 5 pings and the drops back down.

Yes, you are right. This chip has a power-saving feature.

Please try to use these commands to turn this off.

iw dev wlan0 set power_save off #- to disable power save and reduce ping latency.
iw dev wlan0 get power_save  # will return current state.

It worked!!! My ping times went straight down to ~10ms and stayed there. After a quick reboot it appears that power_save gets turned back on, buts that’s fine for me now that I can turn it off quickly if my SSH session is being slow.

Thanks WayneWWW

I’m experiencing the same latency problem but turning off power_save did not fix it for me. Are there other things to try?

Please describe more about your case. Thanks!