Jetson TX2 system time is always wrong

How can I fix Jetson TX2 system time?

Every boot it shows the same date and time.

nvidia@nvidia:~$ date
Mon Nov 11 05:22:11 MST 2019

Ubuntu version:

Distributor ID: Ubuntu
Description:    Ubuntu 18.04.3 LTS
Release:        18.04
Codename:       bionic
systemctl status systemd-timesyncd.service. Tried restarting this service but it didn't help.
● systemd-timesyncd.service - Network Time Synchronization
   Loaded: loaded (/lib/systemd/system/systemd-timesyncd.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-11-11 05:20:09 MST; 6min ago
     Docs: man:systemd-timesyncd.service(8)
 Main PID: 3271 (systemd-timesyn)

I tried following this forum question.But couldn’t fix.

Any leads to fix the Jetson TX2 system time will be great!

Thank you.

Did you connect network? Please have a check the time zone setting and time sync config.
If you did connect the network and always unplug the power the time setting lost is as expect.

I have the same problem. When jetson tx2 connect the network, the date is normal.
However, in our project, no network here. Every boot it shows the same date and time.
Because need to record log, hoping there are different date when boot, the data does not need to be normal.
Is there any way?

You may need HW to connect RTC battery for your case.

Do Original Jetson tx2 have the RTC battery?
Or, Need to add battery by owerself?

You need to add it. Have a reference to below topic.