Jetson Xavier AGX Fan issue: fan does not spin even when module is heated up!

The entire setup was successfully completed via the Jetpack SDK manager. However, when I boot into the Xavier, after some time the entire package becomes immensely hot, yet the fan does not start. Is there a setting or specific driver for the fan?

Instead of " I feel it hot", you can try to dump the tegrastats to know the actual temperature on the device.

Well, using the GUI monitor, I was able to see that the CPU temperatures (for all 8) was around 44 C and for the GPU, it was around 42 C. Important to note, I haven’t even started running my code yet.

The throttle and shutdown thresholds are set to be above 90 C for both. I intend to execute training code on the module, and unless the temperature is maintained in the range of 60-70, I am concerned that the module might get damaged.

I have currently used the command:
systemctl start nvfancontrol

To test whether this service is currently active, use the command:
systemctl is-active nvfancontrol

To stop this service, use the command:
systemctl stop nvfancontrol

Kindly advise.

Are you using cool or quiet profile? The temp for fan to start is different range.

I am unaware as to how to select the profiles - what is the command or in which file do I need to make the changes?

You already answer your own question in previous comment. nvfancontrol can set it.

/etc/nvfancontrol.conf

But how exactly are the profiles selected?

Not quite sure about your question. Could you elaborate it?

Well, there are two profiles, viz., “cool” and “quiet”, right? How do I know which is the current active profile and how do I change it?

Following are the values from the /etc/nvfancontrol.conf (readonly for my user account)

#
# Copyright (c) 2021, NVIDIA CORPORATION.  All rights reserved.
#
# NVIDIA CORPORATION and its licensors retain all intellectual property
# and proprietary rights in and to this software, related documentation
# and any modifications thereto.  Any use, reproduction, disclosure or
# distribution of this software and related documentation without an express
# license agreement from NVIDIA CORPORATION is strictly prohibited.
#

POLLING_INTERVAL 2

<FAN 1>
        TMARGIN DISABLED
        FAN_GOVERNOR pid {
                STEP_SIZE 10
        }
        FAN_PROFILE quiet {
                #TEMP   HYST    PWM     RPM
                0       0       0       0
                50      18      77      1000
                63      8       120     2000
                72      8       160     3000
                81      8       255     4000
                140     0       255     5000
                150     0       255     6000
                160     0       255     7000
                170     0       255     10000
                180     0       255     11000
        }
        FAN_PROFILE cool {
                #TEMP   HYST    PWM     RPM
                0       0       0       0
                35      9       77      1000
                53      8       120     2000
                62      8       160     3000
                73      9       255     4000
                140     0       255     5000
                150     0       255     6000
                160     0       255     7000
                170     0       255     10000
                180     0       255     11000
        }
        THERMAL_GROUP 0 {
                GROUP_MAX_TEMP 108
                #Thermal-Zone Coeffs Max-Temp
                CPU-therm 30,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 0
                GPU-therm 30,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 0
                AUX-therm 40,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0 0
        }
        FAN_DEFAULT_CONTROL open_loop
        FAN_DEFAULT_PROFILE quiet
        FAN_DEFAULT_GOVERNOR pid

Can you dump the full file of your /etc/nvfancontrol.conf?

Edited the dump in the previous reply!

Check the last two line of what you dumped.

So how do I change it to cool? I believe there must be a better way than using root privileges to edit the file to change the default profile to cool?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.