Jetson xavier nx can't find PCIe Device sometime, can it support rescan?

We Connet jetson xavier nx to a pcie switch ,but sometime ,lspci show nothing, we want to recan the pcie bus ? what should we do ?

  • Please make sure that “nvidia,enable-power-down” is removed from the respective PCIe controller’s device-tree node. This makes sure that the root port is at least enumerated (even when the PCIe link is not up with the downstream devices) so that you see only root port’s entry in lspci output.
  • Rescan is not really useful unless the ‘DLActiv’ in the output of respective root port’s ‘sudo lspci vvvv’ is set to ‘+’. Please make sure that it is indeed set. This confirms that the PCIe link is up at a later point of time
  • Now, go to ‘/sys/bus/pci/devices/000x:01:00.0/’ of the respective root port. Replace ‘x’ with the domain of the respective root port and then try ‘rescan’.

I already remove the “nvidia,enable-power-down”, but also can’t find the device.

when I “sudo lspci -vvvv”,I see “DLActiv-”

lspci.txt (7.8 KB)

Ok. In that case, there is no use of running ‘rescan’ as the link itself is not up. I think you need to first root cause the link up issue here.

Ok, Thinks. But My problem is that board sometime link up , but often show link down. My hardware engineer partner think there is no problem on the board hardware link, what should I do to locate the problem?

Try setting “nvidia,max-speed” to ‘1’ instead of the default ‘4’ and also try setting ‘num-lanes’ to ‘1’ from whatever is its default value. If both of them are not helping, connect a PCIe protocol analyzer to find out what is happening (in case if you have access to one of those)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.