Jitter on GPIO

Hello community,

I have built a small tracked robot with the Jetson Nano, using two 12 V motors, a cheap L298N driver, another cheap XL1509 buck converter, a self-built 14,8 Volts battery pack with battery management and the Jetson Nano 2GB. The design is basically from spare parts lying around.

The buck converter only delivers 2A, so I had a bit of trouble with the current supply. I put a small fan on the nano and the moment it started, the initial torque killed the jetson during boot. Without the fan it booted, yet the power LED was blinking all the time. So the buck converters output is wired to 4 pins and I made use of that to power the Jetson via both 5 V inputs on the GPIO. Obviously this had a series connection to 10 Volts and now its working without powering down anymore. Yet always when a motor moves, the Jetson power led blinks once or twice, indicating its still not enough power, I suppose.

Now my problem: I have heavy jitter on all GPIOs (tested them all). During startup the motors move randomly, ok that is to be expected. Yet after that, during idling they always start to move again. When I hit them with the Jetson GPIO library, declaring them to be a low output, the jitter ends and never comes back. So my question is, is this normal or could be due to my hacked power supply ?

I havent altered the factory GPIO configuration via Pimux, I have written a simple software pwm, that toggles the motors in milliseconds during operation that way I can go faster and slower.

Any hints appreciated, wish you a nice weekend :)



Hi entropie1983,

Are you using the devkit or custom board for Jetson Nano 2GB?
What’s the Jetpack version in use?

Could you help to share the full serial console log for further check?

Did you try the test with stable, good enough power supply and unattaching motor devices? The jitter looks like caused by unstable power supply.

Thank you both for your reply and sorry to have bothered you with the question at all, of course it was the power supply. I bought a DC 5V 5A and the jitter is completely gone. Now I have the fan, a CSI camera, an USB dongle and the Jetson hooked up and it works. I still get the over-current warning and the blinking system led, if I run a live video image recognition. All is working tho. I think the buck converter does not live up to his promises and only delivers 3A, there are people commenting about it under the product page. Have to try another one here.
Sry again for bothering you.

For completion:
I have the Waveshare 2GB Jetson Nano kit with and USB-C
The Jetpack Version is 4.6.4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.