Jupyter Labs restart after Jetson reboot

After some trial and error I successfully downloaded and installed the docker container and logging into the JupyterLab Server and completed that module, Now I am trying to proceed to the next module but try to open the page in the same Chrome browser I get a “refuse to connect” error.

I restarted my Jetson as a result of an Ubuntu update, which means the Docker container is still in memory but the course and forum do not provide guidance on how to restart the container and hence lab.

I looked in the forum for restart Docker and restart JupyterLab but no success. Hopefully someone can help me out. Ian

Hi @iverhappen, which container, Jetson, and version of JetPack-L4T are you using?

Are you saying that you started a persistent container and now want to restart it? I think you can use docker restart or docker stop and docker ps -a to find the container ID.

Or are you saying that you get an error since doing an apt upgrade? If there’s an error can you post it here.

I am running the USB Camera container in the script at DLI Getting Started with AI on Jetson Nano | NVIDIA NGC
The recent upgrade installed ubuntu 18.04 LTS, and another update this time asked if I wanted to restart the docker container.
After entering the command “head -n 1 /etc/nv_tegra_release” I received the following response: #R32 release, revision 5.2 GCID 27767740 Board t210ref EABI aarch64 dated July 9, 2021
When I run the commands above here are the responses in the ssh shell

I also noticed when the Jetson started this morning (I had it powered off) a number of items “not running” one of which looked like it was the camera driver.
Hope this helps you getter a better understanding of my problem.

Hi @iverhappen, try using sudo when you run docker commands. I think your user needs to belong to the docker user group if you don’t want to use sudo with it.

Sorry for lag in response. I tried the Sudo command and as you can see in the attached some progress has been made.
Prior to using the Sudo command, I restarted my Jetson and photographed the following notifications that I am now getting as I suspect there may be a correlation.,

Thanks again for your continuing assistance. Ian

sudo docker ps -a
it does not show any container.

Did you start the docker container with run command?
Before start the docker container,
you’d better check that any camera device,CSI or USB, is ready to use.

The USB camera is connected. Please clarify how the “run docker” command should be entered.

The document says;

sudo docker run --runtime nvidia -it --rm --network host
–volume ~/nvdli-data:/nvdli-nano/data
–device /dev/video0 \

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.