K40 + GeForce 210

Hi
I’m trying to install K40 on Ubuntu (14.04 and 16.04) on a Supermicro System, MB X10DAi with one GeForce 210 graphic card. When I install the CUDA Driver it force to disable nouveau and reboot. But when the system reboots I get no video (none)

How to proceed to install K40 on a system with a Nvidia graphic card?

Thanks

GeForce 210 is a compute capability 1.x GPU, and support for these GPUs was dropped after about r343 drivers and after CUDA 6.5.

So if you want to use any recent CUDA version with your K40, then the GeForce 210 is pretty much a non-starter, useless, and an impediment. Replace it with a non-NVIDIA GPU or with a newer NVIDIA display GPU.

If you get a Kepler class or newer NVIDIA (display) GPU, it should work fine with your K40, with any CUDA version at least up to the current CUDA 9.1

Hi

Are that limitation only on Ubuntu? It’s possible to install K40 + GF210 on Centos?
Are there any workaround?

Thanks

The limitations I describe are across-the-board, on all operating systems, both windows and linux. Drivers after r343 do not support GF210, and CUDA toolkits after 6.5 do not support GF210.

I’m not aware of any workarounds. You may discover something, of course.

My recommendation: There is no point in trying to track down four-year old software in order to get a completely outdated Geforce 210 to run. Pick up a modern low-end GP to replace the GeForce 210. You should be able to acquire one for around $75 (GeForce 1030; you may be able to find used Maxwell-based cards even cheaper).

Hi,
I get an ATI and installed a new Ubuntu 16.04 (with K40 out of the board) - works fine
Put K40 at slot, lspci shows both ATI and K40
Boot to console (level 3) and run “sh cuda_9.1.85_387.26_linux.run” - install successfully
nvcc -V show its installed

Boot again on GUI, looked out. Cannot login, after password it goes back to login screen.

what I do wrong?

Thanks.

I am not sure whether Linux can handle drivers from two different vendors graphic card vendors in the same machine. Probably not, or at best with difficulty.

You would want to use your K40 together with an NVIDIA GPU with compute capability >= 3.0.

The problem is when you install CUDA in a scenario where the display is hosted by a non-NVIDIA GPU, you must pass a special switch to the installer.

run the installer with --help to learn about the switches. Look for the --no-opengl-files or --no-opengl-libs switch.

This is covered in the linux install guide and in numerous places on these forums.

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-installation

“If installing the driver, the installer will also ask if the openGL libraries should be installed. If the GPU used for display is not an NVIDIA GPU, the NVIDIA openGL libraries should not be installed. Otherwise, the openGL libraries used by the graphics driver of the non-NVIDIA GPU will be overwritten and the GUI will not work. If performing a silent installation, the --no-opengl-libs option should be used to prevent the openGL libraries from being installed. See the Advanced Options section for more details”

Now that your ATI display is messed up, you’ll need to restore that first, then try the CUDA install. If you can reload the OS and start over, that may be easiest.