Kali Linux Driver Issues . Pls Help

Hi,
I just did a new install of kali linux and then installed nvidia drivers and restarted. Now the screen is stuck in 800x600 resolution none of the nvidia-* packages are working. Pls Help.

Linux Noob Alert

root@kali:~# uname -a
Linux kali 5.7.0-kali1-amd64 #1 SMP Debian 5.7.6-1kali2 (2020-07-01) x86_64 GNU/Linux
root@kali:~# lspci -v 
01:00.0 VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 710] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ZOTAC International (MCO) Ltd. GK208B [GeForce GT 710]
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
        Memory at e8000000 (64-bit, prefetchable) [size=128M]
        Memory at f0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at e000 [size=128]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel modules: nvidia

BUT

root@kali:~# systemctl status systemd-modules-load.service 
● systemd-modules-load.service - Load Kernel Modules
     Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
     Active: failed (Result: exit-code) since Mon 2020-09-14 00:52:03 IST; 35min ago
       Docs: man:systemd-modules-load.service(8)
             man:modules-load.d(5)
    Process: 10313 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
   Main PID: 10313 (code=exited, status=1/FAILURE)

Sep 14 00:52:03 kali systemd-modules-load[10317]: modprobe: ERROR: could not insert 'nvidia': Invalid argument
Sep 14 00:52:03 kali systemd-modules-load[10320]: modprobe: FATAL: Module nvidia-current-modeset not found in directory /lib/modules/5.7.0-kal>
Sep 14 00:52:03 kali systemd-modules-load[10315]: modprobe: ERROR: ../libkmod/libkmod-module.c:990 command_do() Error running install command >
Sep 14 00:52:03 kali systemd-modules-load[10315]: modprobe: ERROR: could not insert 'nvidia_modeset': Invalid argument
Sep 14 00:52:03 kali systemd-modules-load[10321]: modprobe: FATAL: Module nvidia-current-drm not found in directory /lib/modules/5.7.0-kali1-a>
Sep 14 00:52:03 kali systemd-modules-load[10313]: Error running install command 'modprobe nvidia-modeset ; modprobe -i nvidia-current-drm ' fo>
Sep 14 00:52:03 kali systemd-modules-load[10313]: Failed to insert module 'nvidia_drm': Invalid argument
Sep 14 00:52:03 kali systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
Sep 14 00:52:03 kali systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
Sep 14 00:52:03 kali systemd[1]: Failed to start Load Kernel Modules.
root@kali:~# modprobe nvidia
modprobe: FATAL: Module nvidia-current not found in directory /lib/modules/5.7.0-kali1-amd64
modprobe: ERROR: ../libkmod/libkmod-module.c:990 command_do() Error running install command 'modprobe -i nvidia-current ' for module nvidia: retcode 1
modprobe: ERROR: could not insert 'nvidia': Invalid argument

nothing works

root@kali:~# nvidia-debugdump -l
Error: nvmlInit(): Driver Not Loaded
root@kali:~# nvidia-detect 
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK208B [GeForce GT 710] [10de:128b] (rev a1)

Checking card:  NVIDIA Corporation GK208B [GeForce GT 710] (rev a1)
Uh oh. Failed to identify your Debian suite.
root@kali:~# nvidia-smi 
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

root@kali:~# nvidia-settings 

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

Not sure why but I think the drivers fail to start during boot as the systemd service fails because of the missing stuff in

modprobe: FATAL: Module nvidia-current not found in directory /lib/modules/5.7.0-kali1-amd64

Pls Help.