Linux modprob cannot load Nvidia driver

i’m trying to install Nvidia driver for my Kali Linux machine, it was running well with the default nouveau driver.

After the installation, display resolution become very low. So I checked device status with lspci -s 26:00.0 –v And the output is like this

26:00.0 VGA compatible controller: NVIDIA Corporation TU106 [GeForce RTX 2060 Rev. A] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Device 7377:1501
    Flags: bus master, fast devsel, latency 0, IRQ 10, IOMMU group 15
    Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel modules: nvidia

Kernel modules does show Nvidia, but the kernel driver in use is not shown.

I noticed that during boot up, there is an error of System[1]: Failed to start Load Kernel Modules So I checked with systemctl status systemd-modules-load.service command. The output shows nvidia-current and nvidia-current-modeset could not be found as following

     Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
     Active: failed (Result: exit-code) since Thu 2022-06-02 00:54:24 HKT; 7h left
       Docs: man:systemd-modules-load.service(8)
             man:modules-load.d(5)
    Process: 446 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
   Main PID: 446 (code=exited, status=1/FAILURE)
        CPU: 10ms

Jun 02 00:54:24 kali systemd-modules-load[455]: modprobe: FATAL: Module nvidia-current not found in directory /lib/modules/5.15.0-kali3-amd64
Jun 02 00:54:24 kali systemd-modules-load[453]: modprobe: ERROR: ../libkmod/libkmod-module.c:990 command_do() Error running install command 'modprobe -i nvidia-current ' for module nvidia: retcode 1
Jun 02 00:54:24 kali systemd-modules-load[453]: modprobe: ERROR: could not insert 'nvidia': Invalid argument
Jun 02 00:54:24 kali systemd-modules-load[459]: modprobe: FATAL: Module nvidia-current-modeset not found in directory /lib/modules/5.15.0-kali3-amd64
Jun 02 00:54:24 kali systemd-modules-load[451]: modprobe: ERROR: ../libkmod/libkmod-module.c:990 command_do() Error running install command 'modprobe nvidia ; modprobe -i nvidia-current-modeset ' for module nvidia_modeset: retcode 1
Jun 02 00:54:24 kali systemd-modules-load[451]: modprobe: ERROR: could not insert 'nvidia_modeset': Invalid argument
Jun 02 00:54:24 kali systemd-modules-load[464]: modprobe: FATAL: Module nvidia-current-drm not found in directory /lib/modules/5.15.0-kali3-amd64
Notice: journal has been rotated since unit was started, output may be incomplete.

Here is the Nvidia related files under /lib/modules

./modules/5.15.0-kali3-amd64/kernel/drivers/usb/typec/altmodes/typec_nvidia.ko
./modules/5.15.0-kali3-amd64/kernel/drivers/net/ethernet/nvidia/forcedeth.ko

Besides purge all nvidia packages and re-install, I tried to add nouveau to the nvidia-blacklists-nouveau.conf, still the same result. I remember that I have successfully installed this driver once before (about 1-1.5 years ago), I am not sure what went wrong here, any advice is welcomed. Thanks.

GPU: RTX2060 CPU: R5-2600

Please run
sudo modprobe nvidia
and post any errors given.