Kernel panic when Xorg is starting with nvidia drivers versioned ~460.67 - 460.80 on GeForce GTX 1060 with kernels 5.10+

This has been a persistent problem for me for a while now. While I’m unable to pinpoint the exact version and date with which this started occurring, because I only noticed it after doing a upgrade (being a few months behind on updates). Recalling what little I can, I did not have this problem around June 2020 (that’s how far on updates I was). However, after performing my system upgrade on 23rd of March, I was no longer able to boot into my machine (it was when I just installed 5.12 and was trying to run it).
Much to my surprise, switching back to kernel 5.11 also gave me the same result.
Doing a bit of experimentation lead me to the finding that kernels 5.10 and higher would kernel panic when Xorg was starting, while kernels below that version (5.4 ~ 5.9) worked fine.
The logs relevant to those versions are the March-511 and March-512 logs (driver version 460.67).
(kernel 5.12 line 2049 → RIP: 0010:nv_audio_dynamic_power+0xc2/0x140 [nvidia])
(kernel 5.11 line 1611 → RIP: 0010:nv_audio_dynamic_power+0xc2/0x140 [nvidia])

This entire time I’ve been using the 5.9 kernel so I did not have this problem, however, it has now reached its EOL, so I tried switching to 5.10 LTS after performing a system upgrade, hoping the issues was gone. It was not. Kernel versions 5.10+ kernel panic when Xorg is starting, and the versions below it are not compatible with the versions of the packages I have, so I’m in a bit of a pickle here. One thing I did notice however, is that the RIP on which the kernel panic occurs has changed. In the attached May-513 log (driver version 460.80), the RIP is the following:
(kernel 5.13 line 1458 → RIP: 0010:_nv008453rm+0xa8/0x5f0 [nvidia])

I’ve since switched to using nouveau so my system boots properly. There seem to be no problems with booting kernels 5.10 and 5.13 with it.
The nvidia bug report log I’m attaching was generated when I had the nouveau module loaded and not the nvidia ones. I’m also unable to run this bug report after the bug has occurred because the system completely freezes and requires a restart.

The nvidia drivers were installed through pacman.
The reason the title has the affected drivers listed as ~460.67 - 460.80 is because I kept up to date with my system and package updates after that occurred, and after each update, I would try booting using one of the affected kernels (to no avail). The earliest log I have saved has the driver version 460.67 listed, and the latest one has the 460.80 driver listed. The breaking change probably occurred in one of the earlier versions. It is for sure though, one of the driver versions after June 2020, because that was around the last time I updated my system before this whole thing happened.

System seems to boot fine with nvidia modules loaded if I add ‘3’ at the end of the linux boot parameters, but kernel panics as soon as I start the sddm service (in the affected kernel versions).

I’m attaching the relevant journal logs (compressed because I can only post 3 links), as well as the logs from running the nvidia-bug-report script.

journal-logs.zip (91.6 KB)
nvidia-bug-report.log.gz (64.5 KB)

I second this, with a RTX 2070. I am totally unable to correctly boot, with exactly the same error (Kernel Panic, Null pointer).

However, I tested with 5.4, 5.9, 5.10, 5.11 and 5.12, and none worked.
Hope this will be fixed soon