Kitti Format misaligment

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 5
• JetPack Version (valid for Jetson only) 4.4
• TensorRT Version 7
• NVIDIA GPU Driver Version (valid for GPU only) JetPack default

Hi,

I am using deepstream-5.0 app with “kitti-track-output-dir” option to get the bounding boxes. I have a 1280x720 output and a 608x608 tracker.

As per the thread below, it is needed to regularize the output coordinates. However, I get a very strange behavior as in the initial frames, regularization is needed but afterwards is not.

I provide output for the first three frames for an object. It can be observed that the first two frames are referenced to 608x608 tracker but from 3rd frame 1280x720 format is used.

Do you know why this is happening and how can I get the same output format?

Object_1 1 0.0 0 0.0 362.702942 400.007568 437.320343 602.922729 0.0 0.0 0.0 0.0 0.0 0.0 0.0

Object_1 1 0.0 0 0.0 362.543274 399.755768 437.084534 603.174500 0.0 0.0 0.0 0.0 0.0 0.0 0.0

Object_1 1 0.0 0 0.0 763.402771 474.125183 920.226868 713.727905 0.0 0.0 0.0 0.0 0.0 0.0 0.0

Regards,
Alberto

Hey customer, have you resolved your problem referring that topic you posted?

Hi,

No, I still get the same error

Regards,
Alberto

Hey customer,
Are u using DCF tracker? Could you share your DS config and low level tracker config with us?

Hello Customer,

Sounds like you are using the latest DS 5.0 DP version and you set enable-past-frame=1 in [tracker] section in your deepstream-app config. We’ve noticed a similar bug earlier and already fixed it. The GA release that we are planning to release soon will include the fix so you won’t have such issue. Until then, I advise you to set enable-past-frame=0. If so, you won’t have such issue although you also won’t get tracking data during shadow tracking like the frame 0 and frame 1.

Hello,

As you mention I use enable-past-frame=1. I will check the performance with enable-past-frame=0 and will decide best alternative.

Thanks!!
Alberto