L40s in gpumode physical_display_enabled_8GB_bar1 does not show connected displays in control panel


I have a L40s and need to configure it to work in gpumode.
I ran .\displaymodeselector.exe --gpumode physical_display_enabled_8GB_bar1
and then .\nvidia-smi.exe -fdm 0

The nvidia control panel now shows the displayports but when I connect a computer screen to the display port it does not show it as connected and no image output on the display.

Is there any steps that I need to take ? PS. I’ve tested the cables and connectors with a RTX4060 and it works fine.


Hi Sorob,

Malik will contact you for how to get the display output from the DisplayPort of L40S.
Run command “./displaymodeselector.exe --gpumode graphics” to enable physical display port.
And install the the standard Windows driver.