L4T Launcher can't find extlinux

Hi All,

When booting an image for an orin nano devkit from an sd card, I’m getting this message in my uart console:
L4TLauncher: Unable to boot via extlinux: Not Found

The boot then continues successfully by switching to kernel boot. This image was created using dd to clone an image I was working with which had been flashed using the recommended method for the orin nano devkit, premade image and flashing using Balena Etcher. The original image boots normally and does not resort to using kernel boot

I’m attaching the uart log of he boot process, please let me know if you have any insights on what might be causing this. Thanks!
minicom.cap (86.4 KB)

Hi frasc5,

Do you mean that the original image work as expected but the cloned image has issue?
Is there any issue if it showed this messages? It seems still boot up successfully.

Have you tried using SDKM to flash your devkit?

Hi KevinFFF,

Yes, the original image does not display the L4T message about extlinux. It seems to use the kernel, initrd, and DTB from /boot of the rootfs flashed from system.img. The L4T launcher message about extlinux has only appeared for me when using a cloned image (via dd) or when copying the contents of the original image’s rootfs to my own system.img to be used during the flashing process.

As of right now, I can’t ignore the messages. I would like to mount an encrypted rootfs as a partition on my sd card using a separate partition containing /boot. As far as I can tell, for the Orin Nano devkit this is not currently supported by the utilities provided by NVIDIA, please correct me if I have misunderstood this. The current backup kernel that is flashed using flash.sh isn’t able to do this for me.

It seems like the UEFI bootloader can see the extlinux.conf file, but just isn’t able to use extlinux to actually boot the OS. A different message is displayed by the L4T Launcher when the extlinux.conf file is moved from its expected location saying that the extlinux.conf file was not found. I haven’t yet tried using the SDK manager, just the flash.sh script included with the Linux for Tegra package. I can post a log of the flashing process if that would be helpful.

Sorry for the wall of text, I appreciate you getting back to me.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Sorry for the late response, is this still an issue to support? Thanks