Legacy Quadro FX 5500 Driver for Redhat 7.5

I have a NVIDIA Quadro FX 5500 Legacy GPU.

The latest driver for it 304.135 (https://www.nvidia.com/download/driverResults.aspx/114714/en-us) doesn’t seem to support Redhat 7.5. It looks like this GPU is at EOL.

I also tried 334.21 (https://www.nvidia.com/Download/driverResults.aspx/73666/en-us) but it didn’t work.

Is there any driver that will support Redhat 7.5 with this card? Or is the card too old?

If I need to buy a new card what are other options? The new card would have to meet/exceed the FX 5500 specs and support Redhat 7.5.

Any help would be appreciated, thank you!

No chance to use the proprietary driver for it on any decently modern distro. You’re left to use the Noveau driver.
I suspect any modern graphics card surpasses a 16-year old Quadro FX but this doesn’t tell anything about any special requirements you have. What are you using it for?