331.18 Supported video card list is incorrect regarding Quadro NVS 285

According to this page, the Quadro NVS 285 is a supported card for the 331.38 driver:
http://www.nvidia.com/download/driverResults.aspx/72250/en-us

However, the driver gets rejected as “unsupported” when it is attempted to be used. Not sure if the error is in the documentation or the driver.

Ubuntu 12.04.5 LTS Desktop (HWE Trusty) 64 bit
X.Org X Server 1.15.1
Kernel 3.13.0-35-generic

nvidia-bug-report.log.gz (57.9 KB)

Plz provide nvidia bug report by running nvidia-bug-report.sh script as root user .

I added the gzip file created by nvidia-bug-report.sh as an attachment to the first post. Several erros were thrown because the nvidia driver would not load. The following snippet from Xorg.0.log shows the driver refusing to load:

[    23.064] (WW) NVIDIA(0): The NVIDIA Quadro NVS 285 GPU installed in this system is
[    23.064] (WW) NVIDIA(0):     supported through the NVIDIA 304.xx Legacy drivers. Please
[    23.064] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
[    23.064] (WW) NVIDIA(0):     information.  The 331.38 NVIDIA driver will ignore this

Thanks for reporting this, OasisDave. It looks like that’s a mistake in the web page; I’ve notified the web team to get it corrected.

You can get the definitive list of which chips are supported in which branches from Appendix A of the README, which I link from the Current graphics driver releases post. You can also use this URL, which should automatically redirect to the latest version of the README:

http://people.freedesktop.org/~aplattner/nvidia-readme/supportedchips.html

Thanks for confirming. Here is the link to the exact driver version I was asking about. It properly lists the NVS 285 as not supported.

http://us.download.nvidia.com/XFree86/Linux-x86/331.38/README//supportedchips.html