Libargus setWbGains do nothing

Hi,

Hardware TX2 l4t 32.2.1, imx577.

My code:

Argus::BayerTuple< float > wb{ iAutoControlSettings->getWbGains() };
        std::cout << "getWbGains: " << wb[ 0 ] << ", " << wb[ 1 ] << ", " << wb[ 2 ] << ", " << wb[ 3 ] << std::endl;
        wb[ 0 ] = 0.f;
        wb[ 1 ] = 0.f;
        wb[ 2 ] = 0.f;
        wb[ 3 ] = 0.f;
        iAutoControlSettings->setWbGains( wb );
        wb = { iAutoControlSettings->getWbGains() };
        std::cout << "getWbGains: " << wb[ 0 ] << ", " << wb[ 1 ] << ", " << wb[ 2 ] << ", " << wb[ 3 ] << std::endl;

Output:

getWbGains: 1, 1, 1, 1
getWbGains: 0, 0, 0, 0

But the picture has no effect.
Other settings work.

Please help.
Best regards, Viktor.

AWB may not direct observation. Have you try any others value?

Have tried:
getWbGains: 2, 0.5, 2, 0.5
But nothing.

Not sure, but you might have to set awblock to true in order to prevent auto WB adjustments.

Ae and awb locked cause i use manual settings.

If awb mode is manual (or off) and you’ve also disabled auto-exposure, set fixed gain and digital gain, I cannot help further !

Thank you. I wrote to LI. May be it is driver issue.
Will reply here.

Yes.
I should set awb to false, ae to true and awb_mode to manual.
Then RGGB gains works.

Thanks.