linux86/5.1/bin/.pgf90rc

I get the following when trying to execute pgf90:

root@Cordless:/home/jan# pgf90
pgf90-Info-RC file /usr/pgi/linux86/5.1/bin/.pgf90rc line 42: Include file localrc not found
pgf90-Error-Required tool loader was not found
pgf90… looked for loader at /usr/pgi/linux86/5.1/bin/ld
pgf90… looked for loader at /usr/local/sbin/ld
pgf90… looked for loader at /usr/local/bin/ld
pgf90… looked for loader at /usr/sbin/ld
pgf90… looked for loader at /usr/bin/ld
pgf90… looked for loader at /sbin/ld
pgf90… looked for loader at /bin/ld
pgf90… looked for loader at /usr/X11R6/bin/ld
root@Cordless:/home/jan#

I runing it on Ubuntu, and I am a bit of a linux newbie :)

Anyone got any ideas on what I am doing wrong ?

Hi Jacobsen,

The “localrc” file gets created when you install the PGI compilers on your system. So either you haven’t run the install script or your installation failed.

Assuming the install failed and since your using release 5.1, the most likely cause is that the OS your using is too new and the 5.1 installer doesn’t recognize it. Please refer to supported linux release for the complete list of linux releases supported by 5.1. For non-supported systems such as Ubuntu, you need to match your system’s glibc and gcc versions to that of one of the supported systems. It looks like Ubuntu 5.10 uses GCC 4.0.1 and glibc 2.3.5 which means 5.1 won’t work on this system. In this case you’ll need to upgrade to 6.0 which does support glibc 2.3.5 and GCC 4.0.0. You can download the 6.0 compilers here.

Hope this helps,
Mat