Linuxmint 19 with Geforce 1050Ti occurring freezing in action games

Hello

I have a Dell inspiron 7567 notebook that is certified for linux, I installed Linux mint 19 and installed the newer nvidia 396 driver.
However I noticed that in games with a lot of screen movement (usually racer or FPS) sometimes the screen freezes for a few seconds, from 2 to 3.
However heavy games with the more static screen like Cities Skyline the games work without problems.

I checked the temperature of the board and not past the 80, I already tested with other drivers like the 390, but there was no change.

What is most noticeable is that this is the only problem I am having, everything else works well.

I researched the forum and what I found next was these links
https://devtalk.nvidia.com/default/topic/1035363/linux/ubuntu-18-04-screen-tearing-gtx-1050-ti/
https://devtalk.nvidia.com/default/topic/1029100/linux/-gpu-is-present-but-x-server-did-not-work-with-it-geforce-gtx-1050-ti/

According to the above links I activated the ModoSet that was disabled, but it did not work either.

$ sudo cat /sys/module/nvidia_drm/parameters/modeset 
Y

thank you very much if anyone can help me
nvidia-bug-report.log.gz (510 KB)

Since this is an Optimus system, both the intel and nvidia gpu is involved in this. The external HDMI is connected directly to the nvidia gpu, so a test case would be to connect a monitor/TV to that and run the game on the external display and see if the freezes occur.
An oddity in dmesg:

[13901.050710] acpi INT3400:00: Unsupported event [0x86]
[14351.600861] acpi INT3400:00: Unsupported event [0x86]

The event 0x86 is undefined, so this is a bios bug. Nevertheless, this points to something is happening, like AC unplug/plug. So a second test case would be to unplug AC so the system runs on battery and run the game. This should also put the nvidia gpu to lowest clocks and no re-clocking appears.

One of the games that was quite freezing the screen was Dirt, I researched it and found a topic in the steam warning to activate the vsync feature of the game.

https://steamcommunity.com/app/310560/discussions/0/535152276585053103/

One thing I also did though I do not know if it was related was to disable the “Sync to Vblank”

After these two options the game had no problem, now all games need to look for the vsync option to activate it.
You seem to be an expert, does it make sense to change that?

Regarding the 0x86 event, do you recommend doing an update on bios to try to solve this?

Thanks a lot for the help

If a bios update is available for your system, you should apply it.
I don’t completely understand where you disabled/enabled vsync, ‘vsync’ is just short for ‘sync to vblank’.
Unfortunately, there’s no rule for turning on/off vsync in games. Some games run better with vsync on, some run better with vsync off. So for every game you’ll have to try and see.

I have seen on the dell website that there is a newer version of bios (1.6.0 to 1.7.0), I will try to install and speak if it solves in relation to the 0x86 event.

I would like to ask just one more question, sometimes I suspend the notebook and the login screen does not come back, it is only on the black screen I need to turn off using the button.

Have you seen anything related to this?

tks

Suspend problems are not uncommon but it’s easier to debug if those are always happening, not sometimes.
To get more info about that issue, you would have to ssh into the system while frozen after suspend and create a nvidia-bug-report.log that contains the actual error.

I updated Bios this weekend, but unfortunately the 0x86 event continues to occur.

I also noticed other problems like:
after suspending not the screen turns black (wireless network does not return)
when connecting the HDMI cable do not output audio on the TV

Anyway I believe that these problems are no longer related to the initial purpose of the topic, so I will close it and mark its answer as the solution.
At least in my case vsync is making the games perform well!
Thanks a lot for the help!

To have audio over hdmi on TV, you’ll have to use that:
https://github.com/hhfeuer/nvhda
to turn on the audio function of the nvidia gpu.