Lspci is not listing the nvidia RTX 3050ti in VM ubuntu 20.04

Hello All,
I have windows machine and it has the NVidia GeForce RTX 3050ti GPU and I have installed VM, Inside VM, installed the ubuntu 20.04. In VM settings enabled the 3D acceleration.
once, I have logged in VM with ubuntu 20.0, in terminal the lspci command is not showing the NVidia GPU. Tried multiple solution but no luck.

can some one assist me here?

For pci passthrough you need to run a real hypervisor like Vmware esxi, linux kvm or windows server hyper-v. A desktop vitualizer won’t work.

Thanks a lot but you mean VM ware does this virtualization or someone settings needs to be done explicitly? Or in windows virtualization shall be enabled?

I am aware about the virtuvalisation.
I have enabled them in my bios and in my oracle virtual manager, i can see in system tab acceleration, VT-x/AMD-V, Nested pagging, Hyper-V paravirtualisation enabled .
after enabling them my VM not stated .
all i am trying to enable nvidia gpu in ubuntu 20.04

Are you running Windows Server?

No, i am not running windows server

So it won’t work. See my first post.

Sorry to ask you.
I have searched for the post to enable the window server in my XPS 15 9150 but no successful results.
Could you please so kind to share the info to enable the windows server in windows 11

This isn’t something you can “enable” in Windows 11 desktop version (Home/Pro/whatever), it’s a different Windows version for servers. Current Version is “Windows Server 2022”. Windows desktop versions don’t support pci passthrough.

This means there is no possibility to enable GPU support inside oracle VM with ubuntu 20.04 on windows 11 desktop version as a host OS by using free tools.


which means i cannot do CUDA development as well, then there is no use of having Graphics card in my machine which cannot be used in inside linux .

oh god

This works (or at least used to work) using WSL. You wont have a gpu in that evironment but cuda can be used.