M.2 NVMe compatibility

Whould it be possible to post a list of M.2 NVMe drives which were tested to be compatible with Xavier DevKit?

-albertr

Hi albertr,

We do not have comprehensive test of M.2 NVME devices, but generally the one worked on TX1/TX2 should be also working on Xavier.

Thanks

it is not M2, but PCI-E NVME that has been tested to work with Jetson TX2: Intel optane 905P
However, i wont let boot from it, only use as of a data drive has been distinguished.

Andrey1984,

I’m pretty sure there’re plenty of M.2 NVMe cards which would work just fine, I just wanted to check with Nvidia before ordering to make sure to get the “approved” one. Optane 905P is a beast, not sure why would anyone use it in embedded device especially since Xavier DevKit has M.2 Key B slot available…

-albertr

keep an eye on durability and speeds when ordering a ssd, some of them will last 10-20 times longer than others, in my opinion, especially datacenter ssds’. It also seems like in general 1TB is more speedy than 0.5 gb and more durable,and that PCI-E will be faster than M.2 and will not have overheating issues.

I am just wondering if there are tested wifi modules or 3/4g modules that have been tested with xavier. As far as I am concerned to believe, wifi will use M2 [key E], and ssd will utilize M2 [key M]
Reference

Hi Andrey, the dual-band Intel 8265NGW module is formally qualified/supported for the Jetson Xavier devkit. Other Intel wireless modules that use the iwlwifi driver may also work out of the box after the linux-firmware package is installed.

Hi all,

We’re trying to make an ADATA XPG SX6000 M.2 NVMe SSD (Link: https://www.amazon.com/gp/product/B075Y23Y37/ref=ox_sc_act_title_2?smid=A2UXO5LPTDY3LN&th=1) work with the Jetson Xavier dev kit. So far the system is not detecting it and does not appear in the ‘Disks’ utility. Any ideas why this may be the case?

Thanks

does the command below show the device?

lsblk

If anyone is still looking for compatible drives, we have good results with Samsung PM981 512GB drive on Xavier. Before that we were using Samsung PM961 drive with TX2, also with good results. No affiliation or connection to Samsung, just wanted to share our experience.

-albertr

Hi Andrey,

Thanks for the quick reply. I tried it and it does not show the device. It only shows the following:

  • loop0 16M
  • mmcblk0 29.1G (with a bunch of partitions under it)
  • mmcblk0boot0 8M
  • mmcblk0boot1 8M
  • mmcblk0rpmb 4M

Hi albertr,

Thank you. We will probably go with that drive if we cannot get this one to work.

So we got it working with the Samsung 970 PRO NVMe M.2, for anyone who is still trying to set up an SSD on the Jetson Xavier.

I installed a 512GB Samsung 970 Pro NVMe and it’s working fine. I have also written a step by step tutorial on installing the NVMe SSD on the Xavier developer kit if you need instructions:
https://medium.com/@ramin.nabati/installing-an-nvme-ssd-drive-on-nvidia-jetson-xavier-37183c948978

I used this disk, 256 GB, Samsung: https://amzn.to/2pEq7Qg

It works great! I split it in one partition for collecting/recording data and logs (so it doesn’t fill up whatever else is there) and one partition for all my customizations (so I can more easily wipe the EMMC with jetpack.)

gdisk /dev/nvme0n1

(Instead of gdisk, real pros use parted from the command line.)

Use a GPT partition. The partition code for Linux file systems is 8300.
Use

mkfs -t ext4 /dev/nvme0n1p1

for each partition number you want to format with a Linux file system.

Finally, add the file systems to

/etc/fstab

so they are mounted each time you boot.

we are using 500GB Western Digital Blue M.2 SATA3 Solid State Drive, its not being detected

https://www.scanmalta.com/newstore/500gb-western-digital-blue-1-5mm-sata3-solid-state.html

It seems that you are using a M.2 SATA device. However, the Xavier only supports M.2 NVMe SSDs. That could be the problem. Take a look at this topic for more details - https://devtalk.nvidia.com/default/topic/1039438/nvme-ssd-not-recognized/.

Just got a 256GB Samsung 950 Pro M.2 up and running on the Xavier. Standard procedure worked. Tested the read/write speeds and it looks about right. I use the Samsung 950/960s on my desktops/laptops. They’ve been pretty reliable so far.

does it increase overall temperature of the device components when you are using ssd of M.2 type?

sudo apt-get install xsensors
xsensors

The SAMSUNG 970 EVO M.2 2280 2TB PCIe Gen3. X4, NVMe 1.3 SSD MZ-V7E2T0BW is working fine in my Jetson Xavier.