M2025 Linux driver compatibility

Hello,
When trying to get 410.129 Nvidia driver for M2050 GPU card, I get

Then when trying to install this driver, the installer says that my GPU card (M2050) is not supported and the “Legacy 390X” driver should be used instead. Why confusing people by stating on your website that 410.129 is compatible with M2050?

OS: Ubuntu 18.04.3 LTS
kernel: 4.15.0-140-generic #144-Ubuntu SMP

My guess is, that it is a simple human error, like the one you made in your subject.
View that site, which is a pinned topic on this forum, for the list of legacy gpu/drivers:

https://www.nvidia.com/en-us/drivers/unix/legacy-gpu/

Indeed it should have been M2050, I cant see any way of editing submitted question either to correct the mistake in the title.

Doesn’t matter. Those are the remnants of a nvidia pr communications fukup on the v390 driver which said to “deprecate fermi geforce products” while all fermi products (including tesla and quadro) were meant.