Makefile:476: recipe for target 'runtest' failed

Dear sir,
When I do make runtest,caffe shows the message bellow:
F1221 10:25:21.685459 9173 syncedmem.cpp:57] Check failed: error == cudaSuccess (30 vs. 0) unknown error
*** Check failure stack trace: ***
@ 0x7f82f07d95cd google::LogMessage::Fail()
@ 0x7f82f07db433 google::LogMessage::SendToLog()
@ 0x7f82f07d915b google::LogMessage::Flush()
@ 0x7f82f07dbe1e google::LogMessageFatal::~LogMessageFatal()
@ 0x7f82eec22ce8 caffe::SyncedMemory::gpu_data()
@ 0x7f82eec69612 caffe::Blob<>::gpu_data()
@ 0x7f82eecaab4c caffe::ConvolutionLayer<>::Forward_gpu()
@ 0x45bcf2 caffe::Layer<>::Forward()
@ 0x45ec74 caffe::GradientChecker<>::CheckGradientSingle()
@ 0x463633 caffe::GradientChecker<>::CheckGradientExhaustive()
@ 0x752d5f caffe::ConvolutionLayerTest_Test1x1Gradient_Test<>::TestBody()
@ 0x7c86d3 testing::internal::HandleExceptionsInMethodIfSupported<>()
@ 0x7c1cea testing::Test::Run()
@ 0x7c1e38 testing::TestInfo::Run()
@ 0x7c1f15 testing::TestCase::Run()
@ 0x7c31ef testing::internal::UnitTestImpl::RunAllTests()
@ 0x7c3513 testing::UnitTest::Run()
@ 0x451059 main
@ 0x7f82eded6830 __libc_start_main
@ 0x457259 _start
@ (nil) (unknown)
Makefile:476: recipe for target ‘runtest’ failed
make: *** [runtest] Aborted (core dumped)

Please help me how to solve this problem.I am using cuda 8 and cudnn 4.

Do the sample apps that ship with CUDA run correctly?

Dear sir @njuffa,Thanks for your reply.I have compiled and run a model successfully about 7 days before.But when I tried to re train same model,I got some error message and decided to re compile caffe again and during make runtest I got the above message.

Dear sir,I am new in caffe and cuda.So, I am not clear about your comments.Actually,what I need to do?.Please clarify me again please.

Dear sir@njuffa,I run samples,It shows the following message…

habib@habib:~/cuda_samples/NVIDIA_CUDA-8.0_Samples/1_Utilities/deviceQuery$ ./deviceQuery
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 30
-> unknown error
Result = FAIL

habib@habib:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Please tell me the way…how to solve…

Your CUDA install is broken.

It might be that you simply need to reboot the machine.

Otherwise follow the instructions in the linux install guide:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html