Material Not Translating to Composer from 3dsmax 2022

Hey there. So I’m having many issues transferring materials from 3dsmax 2022 to composer. Here’s a simple test example.

  1. I have a plane in max with a material assigned (A max legacy Standard Material), the material has a bitmap of a brick wall.

See image 1

  1. I connect to my omniverse localhost
  2. I go to omniverse, Project, Create new View Project
  3. I create a new project in my Projects directory in my localhost called bricks, and I check MDL Context and Include Dependencies in the materials section.
  4. Create Project
  5. I start USD Composer
  6. In Content, I go to localhost, my bricks project, and open the usd file.

The result is a blank plane with no material.

See image 2

The Plane001 object has a material properly assigned.

See image 3

Any idea what might be going on? Happy to provide any extra info you need.

  • Neil

@neil48 i am slightly confused about step 3. if you plan to use Composer, i don’t think you need to create a “View” Project. i think that’s meant to be OV’s “Presenter” app (Nvidia rebranded it a little while ago; the same time when Create got rebranded to Composer).

as another Max user, hope you don’t mind me interjecting some suggestions - you may find it easier to work with the OV toolbar rather than the menu. Simply connect to your localhost, or server you may have set up, and click on the arrow that points up to export to USD


after you click on the export button, you will be prompted with the location where you’d like to export and a few simple export parameters. you can read more about what each option does from the Max connector doc. i rarely have to adjust the settings with the exception of the “General” rollout where you can specify selection, type, and so on. i don’t normally change the “Material” or “File Output”, especially if you are testing using a plane with a basic texture.


once you are in Composer, you can either double click on the USD you just exported or drag the USD into the stage of a new scene. think of USD as an Xref - opening up the USD will open up the Xref; and dragging the USD into the stage of another stage is referencing it into another USD file.

feel free if you’d like to try again and see how that affects your stage in Composer.

at the time of this writing, not all VRayMtl are supported nor vraybitmap or CoronaMtl. the fact that you are using standard material (legacy) and a simple bitmap texture should come through in USD no problem

Thanks for the reply! So I tried doing all the steps you suggested, and unfortunately it’s still the same result, a slightly green plane with no material.

Since I’m a new user, it would only let me upload a single attachment in my first post, attached to this message is my simple max scene. If you have a moment, could you try the scene and see if it works for you? (142.4 KB)

  • Neil

sure, taking a look at it now and will let you know if i find anything unusual. is it safe to assume you are using the latest Max connector (201.1.0) and Composer (2023.1.1 beta)?

I am using the latest max connector (201.1.0) and I’m using the release version of Composer (2022.3.3). If it works for you, I’ll look into getting the beta of composer and see if that helps.

Thanks for giving it a shot!

  • Neil

oh, i am not sure if the beta release will be the determining factor in resolving the issue. but just wanted to give you a heads up that’s what i used to test your file. i did not see any problems during export and/or getting the texture to show up in Composer 2023.1.1. feel free to check out the brief recording of my process.

and below is what my USD stage looks like inside of the exported “brick.usd” -

Awesome. So I figured out how to install the beta, installed it, and now my file works fine. So looks like it was a bug with 2022.3.3. Thanks for helping me debug this, I appreciate it!

  • Neil

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.