Maximal encoding bitrate


How to encode video with the maximal bitrate that NVidia supports?


Hi igal, do you mean lossless encoding with all frames in qp = 0? H264 or HEVC? What is the resolution?

DaneLLL, hi,

I’d like to encode H.264 at 720p resolution with a bitrate of 32Mbps. How should I accomplish it with GStreamer?

Please refer to

Below is a sample pipeline for your reference:

nvidia@tegra-ubuntu:~$ gst-launch-1.0 nvcamerasrc fpsRange="30 30" num-buffers=300 ! 'video/x-raw(memory:NVMM), width=1280,height=720,framerate=120/1' ! omxh264enc <b>control-rate=2 bitrate=32000000 qp-range=10,35:5,30:-1,-1</b> ! qtmux ! filesink location=a.mp4
Setting pipeline to PAUSED ...

Available Sensor modes :
2592 x 1944 FR=30.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
2592 x 1458 FR=30.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
1280 x 720 FR=120.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
Pipeline is live and does not need PREROLL ...

NvCameraSrc: Trying To Set Default Camera Resolution. Selected sensorModeIndex = 2 WxH = 1280x720 FrameRate = 120.000000 ...

Setting pipeline to PLAYING ...
New clock: GstSystemClock
Framerate set to : 120 at NvxVideoEncoderSetParameterNvMMLiteOpen : Block : BlockType = 4
===== MSENC =====
NvMMLiteBlockCreate : Block : BlockType = 4
NvH264MSEncSetCommonStreamAttribute: LevelIdc conformance violation
NvH264MSEncSetCommonStreamAttribute: LevelIdc conformance violation
===== MSENC blits (mode: 1) into tiled surfaces =====
Got EOS from element "pipeline0".
Execution ended after 0:00:10.190358061
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
nvidia@tegra-ubuntu:~$ ls -all a.mp4
-rw-rw-r-- 1 nvidia nvidia <b>39367213</b> Jun 26 01:57 a.mp4