How to increase the bit rate of encoder?

I use setBitrate to set the bitrate. The format is h265. But it seem that the Maximum value is 250 Mb. How to make it larger. Similarly 300-400Mb?

The upper limit depends on the resolution. What is the resolution in your use-case? If possible, please share a 01_video_encode command for reference.

My resolution is 4k60. I have tested 1080P60 and I also set 400Mb for them. But they are about 250Mb.

It should be hitting upper limit. So you can achieve 250Mbps for 4Kp60 and would like to achieve 400Mbps?

Yes, Can tx2nx do it? Maybe 300 to 500

Please set idrinterval to a small value and qp-range to limited range like:

$ export INFILE=/opt/nvidia/deepstream/deepstream-6.0/samples/streams/sample_1080p_h264.mp4
$ gst-launch-1.0 -e filesrc location=$INFILE ! qtdemux ! h264parse ! nvv4l2decoder ! nvvidconv ! 'video/x-raw(memory:NVMM),width=3840,height=2160' ! videorate ! 'video/x-raw(memory:NVMM),framerate=60/1' ! nvv4l2h264enc maxperf-enable=1 bitrate=400000000 idrinterval=5 qp-range="1,2:1,2:1,2" ! h264parse ! matroskamux ! filesink location=b.mkv

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.