Mesh fitting is inverted on Audio2Face 2021.3.3

Hello,

First of all, thanks very much for this great software!

I have tried Audio2Face with a few meshes before but came across an issue today, where the mesh fits inside out even though the correspondence points appears accurate before fitting.


bossHead_usd.usd (457.4 KB)

Here are a picture of the issue and the usd file for your reference.
Please don’t hesitate if you require any additional info,
Thanks again,
Aurel

Hello @aunthng! Welcome to the community! It looks like the face in the middle may need to seek medical attention… I informed the dev team about the problem. I will post here when I hear back!

1 Like

Hi @aunthng, seems like your mesh has inverted normals.

With inverted normal and mesh cleanup (by exporting to .obj and loading back to maya and exporting to usd), I found this is working good. I’ve attached the updated file too if that helps you.

boss_debug.usd (737.2 KB)

1 Like

That’s great, thanks very much for checking!

Indeed, it looks like the models exported from Houdini have inverted normals in A2F. I tried deleting the nomals of the models and recreate them in Houdini, and same, the face is fitted inside out.

Making the correspondance points from the regular mesh, then exporting the json and importing it back to a model with inverted normals functions but another issue arises down the line, unfortunaly. The blendshape solve does not appear to function.


kit_20220322_115646.log (346.0 KB)

I have attached a picture of the log and the log output file above for you info.

Could this also be due tot he inverted normals?

Thanks very much again

Hi, could you be more specific on this please - which part is not working and how?
The blendshape model (on the right) is not moving while the character transferred one is moving (one in the second left)?
It seems like you followed the process in this tutorial, is that correct?

Seems like your model is too small (like 1/100 size), so the blendshape solve parameters need to be adjusted.
could you tune the settings in image near zero like this and see if it works?

image

Indeed the scale was the issue, thanks very much for the prompt reply!

I pre-scaled the model x100 before the export in Houdini and the blendshape solve functions perfectly then.

Thanks again very much for your help on this!