IndexError: index 2633 is out of bounds for axis 0 with size 2633


I am not able to use Fac2Audio in with several models because I am getting below Error. I am attaching a pic of my Mesh fittings setup:

2021-06-04 03:51:06 [Error] [carb.python] [c:\users\user\appdata\local\ov\pkg\audio2face-2021.2.5\kit\python\lib\asyncio\] Task exception was never retrieved
future: <Task finished coro=<_do_fitting() done, defined at c:\users\user\appdata\local\ov\pkg\audio2face-2021.2.5\exts\omni.kit.charTransfer\omni\kit\charTransfer\> exception=IndexError(‘index 2633 is out of bounds for axis 0 with size 2633’)>
Traceback (most recent call last):
File “c:\users\user\appdata\local\ov\pkg\audio2face-2021.2.5\exts\omni.kit.charTransfer\omni\kit\charTransfer\”, line 69, in _do_fitting
P_l0 = np.hstack([topo_tri_points[landmarks[:, 0]], np.ones(len(landmarks))[:, None]])
IndexError: index 2633 is out of bounds for axis 0 with size 2633

Sorry, but really looking for a support on this one ):

Hi @eng.qassim.ali
Thank you for trying out Audio2Face.
Are you able to share the face geometry for us to take a look?
Would likely need to look at your setup scene as well as it seems the error is on the correspondence index.

1 Like

head5_only.usd (638.0 KB)

I am attaching USD for the head and the setup.
head5_Setup.usd (16.4 MB)

Thank you for the files. Taking a look now.

hi @eng.qassim.ali ,
I’ve recorded this video explaining what is happening and causing the failure and the current suggested workaround. We’ll look into how to prevent this and filter the mesh in the future.

The video appears too large for the forus, so I’ve uploaded it in google drive, here:

Let us know if it works for you, and we appreciate your patience :)


Thanks for your help. The model was exported from Houdini and imported as FBX then converted into Audio2Face.
I’ve add some subdivide, poly doctor and fuse nodes to remove some points and clean the model. But I faced the same problem. I exported the model later to Blender and re-export from Blender without doing anything and guess what! it worked! I do not know how and why. But maybe something you produce from your end and investigate.

1 Like

So, I tired USD cache. But it does not export the blend shapes ? When I imported to Houdini, I noticed that the animation are backed on geo and no blend shapes were exported. I need the blend shapes to match to the original model.

I solved the problem with the imported USD with Attribute Copy Node. It works like a charm!

Hi @eng.qassim.ali ,
Glad to hear that you got it working. Looking forward to see your result :)
Blendshapes support is coming too, so stay tuned :)


Wow! That will be great! Is there a date for this ? XD Sorry asking to much.

We don’t have the exact release date yet.
But it would be after our next patch release for 2021.2

It will definitely be later this year, we will update here as we get closer to release. Thanks.